Bug 447443 - [Feature request] Automatic submission of SELinux AVC denials
[Feature request] Automatic submission of SELinux AVC denials
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 18:02 EDT by Viktor Erdelyi
Modified: 2010-01-21 16:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-21 16:21:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viktor Erdelyi 2008-05-19 18:02:42 EDT
It would be great if there was an option to have Fedora automatically submit
SELinux conflicts to some central server (the ones that pop up in a bubble), and
the Fedora team could select the most common reports and fix them without having
to wait for bugzilla entries.
Just an idea...
Comment 1 Viktor Erdelyi 2008-05-19 18:04:34 EDT
(I actually don't know what those reports are trying to tell me but would be
willing to click on a magic "Send to developers" button :) )
Comment 2 Daniel Walsh 2008-05-19 20:26:03 EDT
I agree, the problem is on the server side.  We need some infrastructure to
handle them and prevent spamming.  Consolodation so we can map similar avc's to
the same problem.
Comment 3 Viktor Erdelyi 2009-03-21 08:14:50 EDT
Just an idea: is it possible to use the same technique that kerneloops uses?
Comment 4 Daniel Walsh 2009-03-23 13:33:02 EDT
That would be the idea or come to a common fedora infrastructure where bugzillas could be reported an triaged.
Comment 5 Bug Zapper 2009-06-09 05:34:57 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Daniel Walsh 2010-01-21 16:21:12 EST
Fixed in Fedora 12.

Note You need to log in before you can comment on or make changes to this bug.