Bug 447480 - Firefox drops characters when typing fast into URL bar
Firefox drops characters when typing fast into URL bar
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 21:52 EDT by Joe Bayes
Modified: 2008-08-27 19:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-27 19:19:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Bayes 2008-05-19 21:52:24 EDT
Description of problem:
When I am typing a URL into firefox, and the pointer is somewhere other than
over the URL bar, firefox will frequently drop a character. For example, I might
type "google foo" and it comes out "goole foo". I'm guessing this has something
to do with the "suggested completions", as the window seems to flash as I type
in the same way that it does when it pops up the suggested completions. A
workaround is to hover the cursor over the URL bar as I type. Another workaround
is to slowly and deliberately type each character, waiting for the display to
update before typing the next character. I am quite positive that this bug is
not due to typographical errors on my part.

Version-Release number of selected component (if applicable):
firefox-3.0-0.60.beta5.fc9.x86_64
...but this bug has been present since long before Firefox 3.

How reproducible:
This doesn't occur every single time I type into the URL bar, but it does happen
more often than not. It is easy to reproduce.

Steps to Reproduce:
1.Open firefox, preferably in an account with a fairly large history. 
2.Select the URL field, then position pointer over the main display area. 
3.Type quickly. 
  
Actual results:
The URL bar contains most of the letters typed.

Expected results:
The URL bar should contain all of the letters typed.

Additional info:
Comment 1 Matěj Cepl 2008-07-28 19:44:03 EDT
Could you reproduce this with the last upgrades of Firefox? This looks like the
stuff which went away before the release.
Comment 2 Joe Bayes 2008-07-31 02:11:57 EDT
Yes, the bug is still there under firefox-3.0.1-1.fc9.x86_64. I think it has
improved somewhat: I now have to type much faster in order to get the bug to
manifest. But I still can make it happen. 

However, it is now nowhere near as annoying as it was. 
Comment 3 Matěj Cepl 2008-07-31 08:01:08 EDT
Hmm, cannot reproduce. Either you are typing extremely fast or you have some
really hopelessly slow computer. Is either of these options possible?
Comment 4 Joe Bayes 2008-08-04 18:35:44 EDT
I type maybe 60wpm, which doesn't seem outrageously fast. I have an Athlon 64 X2 with 1G of ram. 

Since the recent upgrade, it has been much easier to reproduce the problem if I have a lot of tabs open, or if I'm running several large programs at once, or if I Ctrl-T and then immediately start typing. So yeah, there are probably issues with computer speed going on here. 

Since the upgrade, this bug has dropped down into the "minor occasional annoyance" category. I guess you could close it if you want.
Comment 5 Matěj Cepl 2008-08-27 19:19:25 EDT
OK, I will. Please, reopen, if it comes again.

Note You need to log in before you can comment on or make changes to this bug.