Bug 447492 - paper metrics go wrong when printing using lp/lpr
paper metrics go wrong when printing using lp/lpr
Status: CLOSED DUPLICATE of bug 447493
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.1
All Linux
high Severity high
: rc
: ---
Assigned To: Tim Waugh
: Desktop
Depends On:
Blocks: 447493
  Show dependency treegraph
 
Reported: 2008-05-20 00:50 EDT by Hao Liu
Modified: 2008-05-23 10:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-23 10:51:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Text file used to test (5.35 KB, text/plain)
2008-05-22 22:51 EDT, Hao Liu
no flags Details
PPD file for HP Deskjet D1468 (19.68 KB, application/octet-stream)
2008-05-22 22:52 EDT, Hao Liu
no flags Details

  None (edit)
Description Hao Liu 2008-05-20 00:50:57 EDT
Description of problem:
The top and left margin will get slashed when printing using lp/lpr.

Version-Release number of selected component (if applicable):
cups-1.2.4-11.14.el5_1.6

How reproducible:
Always

Steps to Reproduce:
1. Create a plain text file test.txt, make sure it's composed of more than 1
pages, then we can see the four margins:
2. List the available printer:
    $lpstat -p -d
3. Print using lp/lpr
    $lp test.txt -d [PrinterName]
   or
    $lpr test.txt -P [PrinterName]
  
Actual results:
   The top and left margin get slashed.

Expected results:
   All four margins printed normally.

Additional info:
Comment 1 Tim Waugh 2008-05-22 06:09:14 EDT
Need quite a lot more information than this, including:

1. the actual text file you are using
2. the PPD for the queue you are printing to
3. the exact make and model of the printer
4. how you created the queue
5. the output of 'locale'
6. the physical dimensions of the paper you are printing on (is it A4, US
Letter, something else..?)
etc
Comment 2 Hao Liu 2008-05-22 22:51:13 EDT
Created attachment 306440 [details]
Text file used to test
Comment 3 Hao Liu 2008-05-22 22:52:37 EDT
Created attachment 306441 [details]
PPD file for HP Deskjet D1468
Comment 4 Hao Liu 2008-05-22 22:53:29 EDT
(In reply to comment #1)
> Need quite a lot more information than this, including:
> 
> 1. the actual text file you are using

Text file I used to test is attached, Attachment #306440 [details].

> 2. the PPD for the queue you are printing to

PPD file has been attached, Attachment #306441 [details].

> 3. the exact make and model of the printer

Make: HP
Model: Deskjet D1468

> 4. how you created the queue

 $lp test.txt -d [PrinterName]
or
 $lpr test.txt -P [PrinterName]


> 5. the output of 'locale'

$locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=


> 6. the physical dimensions of the paper you are printing on (is it A4, US
> Letter, something else..?)

A4

> etc
> 

Additional information about configurations of my testing machine:

$rpm -q cups
cups-1.2.4-11.18.el5

$rpm -qa | grep fonts
xorg-x11-fonts-base-7.1-2.1.el5
xorg-x11-fonts-truetype-7.1-2.1.el5
tetex-fonts-3.0-33.2.el5_1.2
ghostscript-fonts-5.50-13.1.1
dejavu-lgc-fonts-2.10-1
xorg-x11-fonts-ISO8859-1-75dpi-7.1-2.1.el5
xorg-x11-fonts-misc-7.1-2.1.el5
xorg-x11-fonts-75dpi-7.1-2.1.el5
bitstream-vera-fonts-1.10-7
bitmap-fonts-0.3-5.1.1
liberation-fonts-1.0-1.el5
xorg-x11-fonts-ISO8859-1-100dpi-7.1-2.1.el5
xorg-x11-fonts-100dpi-7.1-2.1.el5
urw-fonts-2.3-6.1.1
xorg-x11-fonts-Type1-7.1-2.1.el5
fonts-chinese-3.02-12.el5

$fc-match Serif
DejaVuLGCSerif.ttf: "DejaVu LGC Serif" "Book"

$fc-match Sans
DejaVuLGCSans.ttf: "DejaVu LGC Sans" "Book"

$fc-match Monospace
DejaVuLGCSansMono.ttf: "DejaVu LGC Sans Mono" "Book"



Sorry for the inconvenience.
Comment 5 Tim Waugh 2008-05-23 10:51:01 EDT

*** This bug has been marked as a duplicate of 447493 ***

Note You need to log in before you can comment on or make changes to this bug.