Bug 4475 - cannot run "xdos"
cannot run "xdos"
Status: CLOSED NEXTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: dosemu (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-11 13:30 EDT by prabirm
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-24 23:20:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description prabirm 1999-08-11 13:30:05 EDT
When I executed "xdos" I got error:
=====>
Error in /var/lib/dosemu/global.conf: (line 643)
Disk-device/file /var/lib/dosemu/hdimage.first doesn't
exist.
<=====
So, I copied existing "/var/lib/dosemu/hdimage" to
"/var/lib/dosemu/hdimage.first". Now I run "xdos"
again and I get error:
======>
[root@localhost /root]# xdos
kernel CPU speed is 233866290 Hz
Running on CPU=586, FPU=1
ERROR: X: Unable to open font "vga"ERROR: , trying "vga"...
ERROR: X: Unable to open font "vga"ERROR: , trying "9x15"...
<======

Then I tried to run "xtermdos" and I get the following
error:
======>
[root@localhost dosemu]# xtermdos
Hey...I could not find the IBM VGA font for xwindows!
To install the VGA font, go into the DOSEMU source directory
and type:
sh xinstallvgafont

Starting xdosemu with default font.  If not using the VGA
font, you should use
the latin character set instead of the PC character set in
/etc/dosemu.conf.

ERROR: No xterm programs found in /usr/X11/bin
Perhaps you don't have Xwindows installed that way?
<========

How do I solve the problem ? BTW, I am running GNOME/KDE
under X perfectly.

Regards,
Prabir
Comment 1 Jay Freeman 1999-09-04 16:34:59 EDT
hdimage.first problem is fixed, don't know if this was always the
case, and you simply didn't have dosemu-freedos installed, or if this
is a more recent fix:

[root(2)@ironclad dosemu]# rpm -q dosemu-freedos
dosemu-freedos-0.99.10-6
[root(2)@ironclad dosemu]# rpm -q --scripts dosemu-freedos
postinstall script (through /bin/sh):
[ -e /var/lib/dosemu/hdimage.first ] || \
    ln -s hdimage.freedos /var/lib/dosemu/hdimage.first
postuninstall script (through /bin/sh):
if [ $1 = 0 ]; then
  if [ -e /var/lib/dosemu/hdimage.first ]; then
    rm -f /var/lib/dosemu/hdimage.first
  fi
fi
Comment 2 Jay Freeman 1999-09-04 16:39:59 EDT
VGA font problem has also been fixed:

[root(2)@ironclad misc]# rpm -q xdosemu
xdosemu-0.99.10-6
[root(2)@ironclad misc]# rpm -ql xdosemu | grep vga
/usr/X11R6/lib/X11/fonts/misc/vga.pcf

Now if only someone at RedHat would notice the added comments and
close the bug report :).
Comment 3 Bill Nottingham 1999-09-24 23:20:59 EDT
OK, we can do that.

Note You need to log in before you can comment on or make changes to this bug.