Bug 447504 - Random bunch of Unicode errors in yum, BZ
Random bunch of Unicode errors in yum, BZ
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 03:51 EDT by Matěj Cepl
Modified: 2014-01-21 18:03 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 13:54:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2008-05-20 03:51:41 EDT
Description of problem:
yum upgrade
[hundreds of lines in between]
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 197, in main
    return exFatal(e)
  File "/usr/share/yum-cli/yummain.py", line 75, in exFatal
    logger.critical('\n\n%s', unicode(e))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 168:
ordinal not in range(128)
[root@hubmaier ~]# 


Version-Release number of selected component (if applicable):
yum-3.2.14-10.fc9.noarch

How reproducible:
100%
Comment 1 Matěj Cepl 2008-05-20 04:09:50 EDT
and now yum clean metadata didn't help:

Running Transaction Test
Finished Transaction Test
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 197, in main
    return exFatal(e)
  File "/usr/share/yum-cli/yummain.py", line 75, in exFatal
    logger.critical('\n\n%s', unicode(e))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 168:
ordinal not in range(128)
[root@hubmaier yum]# 
Comment 2 Matěj Cepl 2008-05-20 05:45:23 EDT
And the winner is .... tramtararaaaa

[root@hubmaier ~]# yum upgrade -y gtk2-debuginfo
Loaded plugins: allowdowngrade, changelog, downloadonly, protectbase, refresh-
              : packagekit, security, versionlock
Excluding Packages in global exclude list
Finished
Reading version lock configuration
0 packages excluded due to repository protections
Skipping security plugin, no data
Setting up Upgrade Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package gtk2-debuginfo.x86_64 0:2.13.0-2.fc10 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 gtk2-debuginfo          x86_64     2.13.0-2.fc10    rawhide-debuginfo  7.6 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total size: 7.6 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 193, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 405, in doTransaction
    errstring += '  %s\n' % descr 
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 143:
ordinal not in range(128)
[root@hubmaier ~]# rpm -Uvh
/var/cache/yum/rawhide-debuginfo/packages/gtk2-debuginfo-2.13.0-2.fc10.x86_64.rpm 
Preparing...                ########################################### [100%]
	soubor /usr/lib/debug/usr/lib64/gtk-2.0/modules/libferret.so.debug z instalace
gtk2-debuginfo-2.13.0-2.fc10.x86_64 koliduje se souborem z balíčku
gail-debuginfo-1.22.1-1.fc9.x86_64
	soubor /usr/lib/debug/usr/lib64/gtk-2.0/modules/libgail.so.debug z instalace
gtk2-debuginfo-2.13.0-2.fc10.x86_64 koliduje se souborem z balíčku
gail-debuginfo-1.22.1-1.fc9.x86_64
	soubor /usr/lib/debug/usr/lib64/libgailutil.so.18.0.1.debug z instalace
gtk2-debuginfo-2.13.0-2.fc10.x86_64 koliduje se souborem z balíčku
gail-debuginfo-1.22.1-1.fc9.x86_64
[root@hubmaier ~]# 

Of course, there is a bug in gtk2-debuginfo, but yum shouldn't crash on it.
Comment 3 Dhaval Giani 2008-05-20 07:24:55 EDT
hit the same bug, nope, this one does not resolve it for me. i am on the latest
gtk2-debuginfo already according to yum

[root@mordor ~]# yum upgrade -y gtk2-debuginfo
Loaded plugins: presto, refresh-packagekit
Setting up and reading Presto delta metadata
No Presto metadata available for fedora
No Presto metadata available for livna-development
No Presto metadata available for adobe-linux-i386
No Presto metadata available for updates
Setting up Upgrade Process
Could not find update match for gtk2-debuginfo
No Packages marked for Update
[root@mordor ~]# 

I get the same trace when I do a yum update
Comment 4 Matěj Cepl 2008-05-20 09:19:11 EDT
(In reply to comment #3)
> hit the same bug, nope, this one does not resolve it for me. i am on the latest
> gtk2-debuginfo already according to yum

Then do what I did -- a binary search -- i.e., upgrade all g\* packages, if that
works, upgrade lib\* packages, until you find the package which is broken.
Comment 5 James Antill 2008-05-20 09:46:08 EDT
 Can you try changing:

logger.critical('\n\n%s', unicode(e))

...to:

logger.critical('\n\n%s', to_utf8(unicode(e)))

...and you'll need to put a "from misc import to_utf8" at the top of the file.
Comment 6 Matěj Cepl 2008-05-20 10:56:08 EDT
I am not sure, I can reproduce it here -- after rpm -e gail-debuginfo I have
working yum upgrade. I needed machine to be working, so I fixed it by hand
(well, I wish it was workin -- it is Rawhide, so it is broken, but that's not
your problem ;-)).
Comment 7 Jan Hutař 2008-09-10 05:10:14 EDT
These bugs were mostly fixed, so I guess this one can be closed.
Comment 8 Arnaud Gomes-do-Vale 2008-10-30 07:42:44 EDT
Looks like it is still in rawhide as of today. I had to unset LANG and LC_ALL to run "yum upgrade".
Comment 9 James Antill 2008-10-30 09:52:27 EDT
What version of yum do you have (yum --version) ... and what does the error look like?
Comment 10 Arnaud Gomes-do-Vale 2008-10-30 10:27:54 EDT
It looks like I can't reproduce it anymore. I guess something was updated by said "yum upgrade" which fixed the problem. I had yum-3.2.19-5.fc10 before the upgrade, now yum-3.2.20-3.fc10.

Sorry for the noise.
Comment 11 Bug Zapper 2008-11-25 21:18:08 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 seth vidal 2009-01-21 13:54:12 EST
hopefully.

Note You need to log in before you can comment on or make changes to this bug.