Bug 447524 - top column order differs from one update to the next
top column order differs from one update to the next
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: procps (Show other bugs)
4.8
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Tomas Smetana
Brian Brock
GSSApproved
: ZStream
Depends On:
Blocks: 450112
  Show dependency treegraph
 
Reported: 2008-05-20 06:58 EDT by Adam Stokes
Modified: 2014-01-15 12:29 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0706
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:53:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Stokes 2008-05-20 06:58:23 EDT
Description of problem:
We found the order of output fields displayed by top command in RHEL4.6 is
different from RHEL4.5 (include versions below RHEL4.5).

The following is the header of processed information which is displayed by top
command in RHEL4.5 (include versions below RHEL4.5).

   PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND

The following is the header of processed information which is displayed by top
command in RHEL4.6.

   PID USER      PR  NI  %CPU  TIME+  VIRT  RES  SHR S %MEM   COMMAND

Though the count of fields and the name of fields is not changed, but the order
of fields is different.

Version-Release number of selected component (if applicable):
procps-3.2.3-8.9

How reproducible:
100%

Steps to Reproduce:
1.run top on previous version
2.run top on stated version above
3.
  
Actual results:
PID USER      PR  NI  %CPU  TIME+  VIRT  RES  SHR S %MEM   COMMAND

Expected results:
same output as previous released top on RHEL4

Additional info:
This was introduced by BZ/patch :
https://bugzilla.redhat.com/show_bug.cgi?id=240363
Comment 2 RHEL Product and Program Management 2008-05-20 07:02:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 RHEL Product and Program Management 2008-05-20 07:16:20 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 23 errata-xmlrpc 2008-07-24 15:53:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0706.html

Note You need to log in before you can comment on or make changes to this bug.