Bug 447552 - Fedora 9 Installation "no drives found" Mylex DAC960
Fedora 9 Installation "no drives found" Mylex DAC960
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
9
i686 Linux
low Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 10:33 EDT by Kelvin J. Hill
Modified: 2013-01-10 16:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 14:18:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal output as requested. (68.90 KB, text/plain)
2008-05-20 11:34 EDT, Kelvin J. Hill
no flags Details
dmesg for FC8 DAC960 and sym53c8xx (16.96 KB, text/plain)
2008-05-22 19:50 EDT, Aaron Gray
no flags Details
lshal output for FC8 (39.13 KB, text/plain)
2008-05-23 10:55 EDT, Aaron Gray
no flags Details
lshal listing from ctrl-alt-F2 during f9 install when no drives found (60.32 KB, text/plain)
2008-06-22 00:35 EDT, Michael Osborne
no flags Details

  None (edit)
Description Kelvin J. Hill 2008-05-20 10:33:36 EDT
Description of problem: 

Anaconda does not permit installation to /dev/rd/c0d0 device provided by DAC960
RAID controller. This worked perfectly under Fedora 8. The device is seen by
both parted and fdisk when booted off the Fedora 9 installation media but
Anaconda refuses to recognize it as an installation target. System is an older
Intel L440GX+ motherboard. Details are:-

dmidecode from Fedora8
======================
Base Board Information
        Manufacturer: Intel
        Product Name: L440GX+
        Version: 721242-012
BIOS Information
        Vendor: Intel Corporation
        Version: L440GX0.86B.0133.P14.0103261759 
        Release Date: 03/26/01

lspci from Fedora8
=====================
00:0b.1 0104: 1069:0010 (rev 05) 

00:0b.1 RAID bus controller: Mylex Corporation DAC960PG (rev 05)
        Subsystem: Mylex Corporation DAC960PG
        Flags: bus master, medium devsel, latency 64, IRQ 18
        Memory at f4106000 (32-bit, prefetchable) [size=8K]
        Capabilities: [80] Power Management version 2
        Kernel driver in use: DAC960
        Kernel modules: DAC960

Version-Release number of selected component (if applicable):


How reproducible:

Attempt to install Fedora 9 on the above hardware.


Steps to Reproduce:
1. Boot installation media in gui mode.
2. Proceed to disk partitioning selection in anaconda.
3. Attempt to select any option and go to next screen.
  
Actual results:

Error dialog of "No Drives Found" is displayed.

Expected results:

Display of /dev/rd/c0d0 as a valid install target in the same manner as that
shown in Fedora 8 installation.

Additional info:

This is a complete show-stopper for this target hardware. Fedora 8 seems to be
the last version that can be installed.
Comment 1 Kelvin J. Hill 2008-05-20 10:42:33 EDT
dmesg from Fedora 8
===================

ACPI: PCI Interrupt 0000:00:0b.1[A] -> GSI 18 (level, low) -> IRQ 18
DAC960: ***** DAC960 RAID Driver Version 2.5.49 of 21 Aug 2007 *****
DAC960: Copyright 1998-2001 by Leonard N. Zubkoff <lnz@dandelion.com>
DAC960#0: Configuring Mylex DAC960PTL1 PCI RAID Controller
DAC960#0:   Firmware Version: 4.08-0-37, Channels: 1, Memory Size: 16MB
DAC960#0:   PCI Bus: 0, Device: 11, Function: 1, I/O Address: Unassigned
DAC960#0:   PCI Address: 0xF4106000 mapped at 0xF8880000, IRQ Channel: 18
DAC960#0:   Controller Queue Depth: 124, Maximum Blocks per Command: 128
DAC960#0:   Driver Queue Depth: 123, Scatter/Gather Limit: 33 of 33 Segments
DAC960#0:   Stripe Size: 64KB, Segment Size: 8KB, BIOS Geometry: 255/63
DAC960#0:   Physical Devices:
DAC960#0:     0:0  Vendor: SEAGATE   Model: ST336704LW        Revision: 0003
DAC960#0:          Serial Number: 3CD023JK000010360S1Q
DAC960#0:          Disk Status: Online, 71686144 blocks
DAC960#0:     0:1  Vendor: FUJITSU   Model: MAP3367NP         Revision: 0106
DAC960#0:          Serial Number: UPS0P3200GPC
DAC960#0:          Disk Status: Online, 71686144 blocks
DAC960#0:     0:2  Vendor: SEAGATE   Model: ST336704LW        Revision: 0003
DAC960#0:          Serial Number: 3CD033XM000010360CEB
DAC960#0:          Disk Status: Online, 71686144 blocks
DAC960#0:   Logical Drives:
DAC960#0:     /dev/rd/c0d0: RAID-5, Online, 143372288 blocks, Write Thru
 rd/c0d0: p1 p2
Comment 2 Jeremy Katz 2008-05-20 10:44:01 EDT
Can you attach the lshal output?
Comment 3 Kelvin J. Hill 2008-05-20 11:34:26 EDT
Created attachment 306139 [details]
lshal output as requested.
Comment 4 Jeremy Katz 2008-05-20 11:46:29 EDT
The block devices don't show up in hal, so anaconda doesn't see them
Comment 5 Kelvin J. Hill 2008-05-20 11:52:09 EDT
This is a change from Fedora 8's method of working? How do we resolve this?
There must be thousands of these machines in operation still. I have 3 sitting
right next to me.
Comment 6 Aaron Gray 2008-05-22 18:54:15 EDT
Having simular problem with Mylex DAC960PRL and LSI Corp sym53c8xx SCSI 
controllers on Pentium III hardware on both F9 and rawhide. Anaconda is not 
detecting either of these controllers.
Comment 7 Aaron Gray 2008-05-22 19:50:18 EDT
Created attachment 306431 [details]
dmesg for FC8 DAC960 and sym53c8xx
Comment 8 Kelvin J. Hill 2008-05-23 03:12:50 EDT
Hi Aaron, I noticed that you have raised this issue in the past, and that nobody
had solved it. This is why I raised this Bugzilla entry.

I suggest that you also attach your "lshal" output. It seems that anaconda is
now HAL dependent.

Comment 9 Aaron Gray 2008-05-23 10:55:20 EDT
Created attachment 306507 [details]
lshal output for FC8
Comment 10 Leon Stringer 2008-06-13 11:29:44 EDT
I see this with Fedora 9 and a Mylex AcceleRAID 352 which I think uses the same
chipset. Again Fedora 8 appears to install fine on this.
Comment 11 Michael Osborne 2008-06-22 00:35:48 EDT
Created attachment 309992 [details]
lshal listing from ctrl-alt-F2 during f9 install when no drives found
Comment 12 Michael Osborne 2008-06-22 00:38:23 EDT
Comment on attachment 309992 [details]
lshal listing from ctrl-alt-F2 during f9 install when no drives found

I've got the same problem. SC450NX MP Intel motherboard with 4 x P3 Xeons,
Mylex  AcceleRAID 200 controller. 

No drives are found by anaconda during install. Checking C-A-F2 at this point
shows that the DAC960 driver is loaded and all drives and partitions can be
seen by fdisk -l.

lshal (under f9) is attached shows the DAC960 controller, but no drives or
Comment 13 Jesse Keating 2008-10-03 19:15:36 EDT
Not that I expect much different, but have you tried the F10 Beta on this?
Comment 14 Jesse Keating 2008-10-24 20:20:52 EDT
There hasn't been any input on this in a while.  I would really like to see somebody with this hardware to verify if this is working or not.  Either way I don't expect that to happen for F10, but I don't think this is an F10 blocker.  Removing from the blocker.
Comment 15 Michael Osborne 2008-11-22 00:49:43 EST
Finally was able to get to were I could test this on my SC450NX server. This is the same system tested for F9. Same failure. :-( Anaconda sees no drives for installation. The DAC960 controller is listed in lshal and disks and partitions are accessible via shell.
Comment 16 Kelvin J. Hill 2008-11-22 13:08:48 EST
I am somewhat disappointed that this is not considered to be a blocker for F10. It has completely crippled the use of F9 on a number of servers here that use the DAC960 controller. It now seems that this is going to be the case for F10 as well.

I guess that we will have to migrate to some other distribution to enable us to move forward with Linux on these platforms. At the moment EL5 is being used on them but I presume that the next "EL" version from RedHat will be based on a recent Fedora version, thereby bringing the issue into the commercial stream. 

I personally think that anaconda should not be so bound up in what HAL can manage but allow a fallback position to support legacy non-HAL devices as well if a suitable HAL device is not available.
Comment 17 Peder Strand 2008-12-08 05:10:31 EST
I didn't notice this until I tried a new f10 install on another system.

I have made an yum upgrade from f8-f9-f10 on my systems.

It seems that the only way to run f9 and newer is to install f8 and do an yum upgrade in several steps. But the time is running out, f8 is soon to be EOL.

Is it possible to make a driver disk workaround on the f10 install, to make it recognize the DAC960 ?
Comment 18 Bug Zapper 2009-06-09 21:02:15 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 19 Bug Zapper 2009-07-14 14:18:15 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.