Bug 447555 - Lots of these in /var/log/messages: " Poker test failed!"
Lots of these in /var/log/messages: " Poker test failed!"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: audio-entropyd (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 10:43 EDT by Tom London
Modified: 2008-09-11 13:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-11 13:02:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-05-20 10:43:53 EDT
Description of problem:
I notice a very large number (>160K) messages like:

May 20 07:06:50 localhost audio-entropyd: Poker test failed! [83.499200]
May 20 07:06:50 localhost audio-entropyd: Poker test failed! [82.910400]
May 20 07:06:50 localhost audio-entropyd: Poker test failed! [84.222400]
May 20 07:06:50 localhost audio-entropyd: Poker test failed! [83.806400]
May 20 07:06:50 localhost audio-entropyd: Poker test failed! [83.896000]
May 20 07:06:50 localhost audio-entropyd: Poker test failed! [84.484800]
May 20 07:06:50 localhost audio-entropyd: Poker test failed! [84.484800]
May 20 07:06:50 localhost audio-entropyd: Poker test failed! [84.497600]
May 20 07:06:50 localhost audio-entropyd: Poker test failed! [84.350400]
May 20 07:06:50 localhost audio-entropyd: Poker test failed! [84.465600]

in /var/log/messages.

Typical sequence in /var/log/messages looks like:
May 20 06:34:58 localhost kernel: ALSA sound/pci/hda/hda_codec.c:725:
hda_codec_cleanup_stream: NID=0x4
May 20 06:34:59 localhost kernel: ALSA sound/pci/hda/hda_codec.c:725:
hda_codec_cleanup_stream: NID=0x4
May 20 06:34:59 localhost audio-entropyd: Poker test failed! [46.225600]
May 20 06:34:59 localhost kernel: ALSA sound/pci/hda/hda_codec.c:725:
hda_codec_cleanup_stream: NID=0x4
May 20 06:35:00 localhost audio-entropyd: Poker test failed! [46.654400]
May 20 06:35:00 localhost audio-entropyd: Poker test failed! [46.904000]
May 20 06:35:00 localhost audio-entropyd: Poker test failed! [46.590400]
<<<SNIP   hundreds of the above....>>>

I'm running latest Rawhide (kernel-2.6.26-0.17.rc3.fc10.i686 and associated
pulse packages, etc.).



Version-Release number of selected component (if applicable):
audio-entropyd-1.0.1-2.fc9.i386

How reproducible:
Just about every boot, don't know what triggers it.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-06-17 10:41:57 EDT
Have seen this with latest Rawhide kernel: kernel-2.6.26-0.72.rc6.git2.fc10.i686

Here is some additional context from /var/log/messages:

Jun 13 21:35:02 localhost audio-entropyd: test of random data failed, skipping
2500 bytes before re-using data-stream (0 bytes in flush)
Jun 13 21:35:02 localhost kernel:<4>ALSA sound/pci/hda/hda_codec.c:725:
hda_codec_cleanup_stream: NID=0x4
Jun 13 21:35:03 localhost kernel:<4>ALSA sound/pci/hda/hda_codec.c:725:
hda_codec_cleanup_stream: NID=0x4
Jun 13 21:35:03 localhost kernel:<4>ALSA sound/pci/hda/hda_codec.c:725:
hda_codec_cleanup_stream: NID=0x4
<<<<<<SNIP>>>>>>
Jun 13 21:35:37 localhost kernel:<4>ALSA sound/pci/hda/hda_codec.c:725:
hda_codec_cleanup_stream: NID=0x4
Jun 13 21:35:37 localhost kernel:<4>ALSA sound/pci/hda/hda_codec.c:725:
hda_codec_cleanup_stream: NID=0x4
Jun 13 21:35:38 localhost kernel:<4>ALSA sound/pci/hda/hda_codec.c:725:
hda_codec_cleanup_stream: NID=0x4
Jun 13 21:35:38 localhost audio-entropyd: Poker test failed! [75.307200]
Jun 13 21:35:38 localhost audio-entropyd: Runs-test failed!
Jun 13 21:35:38 localhost audio-entropyd: Poker test failed! [76.324800]
Jun 13 21:35:38 localhost audio-entropyd: Poker test failed! [76.721600]
Jun 13 21:35:38 localhost kernel:<4>ALSA sound/pci/hda/hda_codec.c:725:
hda_codec_cleanup_stream: NID=0x4

I am not getting this every boot.  Don't know what triggers this.
Comment 2 Raymond Steven Kutai 2008-08-03 22:05:04 EDT
kernel:  kernel-2.6.25.11-97.fc9.i686
audio-entropyd: audio-entropyd-1.0.1-2.fc9.i386

I just erased a 2G /var/log/messages that filled up over the weekend.
I have 5 PCs. 2 showing failures as per Comment #1. The other three did not.
Failures are the same as per the main description and Comment #1

In addition I also noted thousands of lines w/:
Jul 30 14:35:09 journey audio-entropyd: Monobit test failed! [9364]
and

Jul 30 14:35:07 journey audio-entropyd: Runs-test failed!

/var/log/messages is just too HUGE to scroll all the way through.
Comment 3 Tom "spot" Callaway 2008-08-04 10:55:38 EDT
(In reply to comment #2)
> kernel:  kernel-2.6.25.11-97.fc9.i686
> audio-entropyd: audio-entropyd-1.0.1-2.fc9.i386
> 
> I just erased a 2G /var/log/messages that filled up over the weekend.
> I have 5 PCs. 2 showing failures as per Comment #1. The other three did not.
> Failures are the same as per the main description and Comment #1

Okay, what kind of audio device are in these machines? I'm suspicious that all of these failures might be happening on a specific audio device driver (intel hda).
Comment 4 Tom London 2008-08-04 11:53:23 EDT
Thinkpad X60, Intel, Intel, Intel:

[tbl@localhost ~]$ /sbin/lsmod | grep intel
kvm_intel              41780  1 
kvm                   116836  1 kvm_intel
snd_hda_intel         361804  5 
snd_pcm                67244  3 snd_hda_intel,snd_pcm_oss
snd_page_alloc         11272  2 snd_hda_intel,snd_pcm
snd_hwdep              10764  1 snd_hda_intel
snd                    52324  17 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
[tbl@localhost ~]$
Comment 5 Raymond Steven Kutai 2008-08-04 12:20:17 EDT
These are the three _always_on_ PCs. 2 w/ failures 1 w/o
there are two others, I need 2 wait till the next working hours
for the owners to turn them on.

The PC w/ 2G log (hobbes):
rkutai@hobbes ~]$ sudo lsmod | grep snd
[sudo] password for rkutai: 
snd_intel8x0           30492  3 
snd_ac97_codec         94368  1 snd_intel8x0
ac97_bus                5504  1 snd_ac97_codec
snd_seq_dummy           6660  0 
snd_seq_oss            30364  0 
snd_seq_midi_event      9600  1 snd_seq_oss
snd_seq                48448  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10124  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42496  0 
snd_mixer_oss          16768  2 snd_pcm_oss
snd_pcm                67076  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              21640  2 snd_seq,snd_pcm
snd                    48312  14 snd_intel8x0,snd_ac97_codec,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9288  2 snd
snd_page_alloc         11400  2 snd_intel8x0,snd_pcm

The other one is (lupin):
[rkutai@lupin fedora]$ sudo lsmod | grep snd
snd_intel8x0           30492  3 
snd_ac97_codec         94368  1 snd_intel8x0
ac97_bus                5504  1 snd_ac97_codec
snd_seq_dummy           6660  0 
snd_seq_oss            30364  0 
snd_seq_midi_event      9600  1 snd_seq_oss
snd_seq                48448  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10124  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42496  0 
snd_mixer_oss          16768  2 snd_pcm_oss
snd_pcm                67076  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              21640  2 snd_seq,snd_pcm
snd                    48312  14 snd_intel8x0,snd_ac97_codec,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9288  2 snd
snd_page_alloc         11400  2 snd_intel8x0,snd_pcm

No failure on this machine (akira):
[root@akira fedora]# lsmod | grep snd
snd_hda_intel         336928  3 
snd_seq_dummy           6660  0 
snd_seq_oss            30364  0 
snd_seq_midi_event      9600  1 snd_seq_oss
snd_seq                48448  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10124  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42496  0 
snd_mixer_oss          16768  2 snd_pcm_oss
snd_pcm                67076  2 snd_hda_intel,snd_pcm_oss
snd_timer              21640  2 snd_seq,snd_pcm
snd_page_alloc         11400  2 snd_hda_intel,snd_pcm
snd_hwdep              10500  1 snd_hda_intel
snd                    48312  14 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore               9288  2 snd
Comment 6 Tom "spot" Callaway 2008-08-04 12:41:08 EDT
(In reply to comment #5)
> These are the three _always_on_ PCs. 2 w/ failures 1 w/o
> there are two others, I need 2 wait till the next working hours
> for the owners to turn them on.

And these are all F9 systems with the same kernel running on each?
Comment 7 Raymond Steven Kutai 2008-08-07 13:36:56 EDT
All PCs are Fedora 9 w/ kernel 2.6.25.11-97.fc9

Here are the other two unaffected PCs.  I noted that PCs w/ intel hda drivers were not affected, while two w/ intel8x0 were badly affected, but the last PC (journey w/ intel8x0) was not affected. (I did grepped through the /var/log/messages* logs for all the PCs.)  I found that the failures occurred during the weekend (Sat, Sun, and until the service audio-entropyd restarted on Mondays.) 

[rkutai@cleon ~]$ sudo lsmod | grep snd
snd_hda_intel         336928  2 
snd_seq_dummy           6660  0 
snd_seq_oss            30364  0 
snd_seq_midi_event      9600  1 snd_seq_oss
snd_seq                48448  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10124  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42496  0 
snd_mixer_oss          16768  1 snd_pcm_oss
snd_pcm                67076  2 snd_hda_intel,snd_pcm_oss
snd_timer              21640  2 snd_seq,snd_pcm
snd_page_alloc         11400  2 snd_hda_intel,snd_pcm
snd_hwdep              10500  1 snd_hda_intel
snd                    48312  14 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore               9288  1 snd

[root@journey ~]# lsmod | grep snd
snd_intel8x0           30492  4 
snd_ac97_codec         94368  1 snd_intel8x0
ac97_bus                5504  1 snd_ac97_codec
snd_seq_dummy           6660  0 
snd_seq_oss            30364  0 
snd_seq_midi_event      9600  1 snd_seq_oss
snd_seq                48448  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_mpu401             10892  1 
snd_mpu401_uart        10240  1 snd_mpu401
snd_pcm_oss            42496  0 
snd_mixer_oss          16768  3 snd_pcm_oss
snd_pcm                67076  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_rawmidi            22400  1 snd_mpu401_uart
snd_seq_device         10124  4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd_timer              21640  2 snd_seq,snd_pcm
snd                    48312  19 snd_intel8x0,snd_ac97_codec,snd_seq_dummy,snd_seq_oss,snd_seq,snd_mpu401,snd_mpu401_uart,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_rawmidi,snd_seq_device,snd_timer
snd_page_alloc         11400  2 snd_intel8x0,snd_pcm
soundcore               9288  3 snd
Comment 8 Fedora Update System 2008-08-07 16:48:44 EDT
audio-entropyd-1.0.1-4.fc8 has been submitted as an update for Fedora 8
Comment 9 Fedora Update System 2008-08-07 16:49:45 EDT
audio-entropyd-1.0.1-4.fc9 has been submitted as an update for Fedora 9
Comment 10 Tom "spot" Callaway 2008-08-07 16:51:08 EDT
Please give this update a try, I'm pretty sure it will silence all that log filling noise. I think this is just unnecessary debugging information, since the randomization pool is still being filled.

https://admin.fedoraproject.org/updates/F9/pending/audio-entropyd-1.0.1-4.fc9
Comment 11 Fedora Update System 2008-08-12 14:20:15 EDT
audio-entropyd-1.0.1-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audio-entropyd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7149
Comment 12 Fedora Update System 2008-08-12 14:22:47 EDT
audio-entropyd-1.0.1-4.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audio-entropyd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7178
Comment 13 Raymond Steven Kutai 2008-08-20 04:11:13 EDT
"audio-entropyd: Poker test failed!" no longer appears in /var/log/messages
after applying the above update (FEDORA-2008-7178).

TQ
Comment 14 Fedora Update System 2008-09-11 13:02:43 EDT
audio-entropyd-1.0.1-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2008-09-11 13:04:32 EDT
audio-entropyd-1.0.1-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.