Bug 447584 - GCC 4.3 compilation error in Wine 1.0-rc1
GCC 4.3 compilation error in Wine 1.0-rc1
Status: CLOSED DUPLICATE of bug 440139
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 12:15 EDT by Zoltan Boszormenyi
Modified: 2008-05-20 12:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-20 12:28:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zoltan Boszormenyi 2008-05-20 12:15:11 EDT
Description of problem:

I used to compile my own Wine RPMs using the official Fedora Wine SRPM specfile
(sometimes with needed modifications). Fedora 9's GCC 4.3 is unable to compile
Wine 1.0-rc1 which was successful with F8 GCC 4.1.2. The error message:

gcc -m32 -c -I. -I. -I../../../include -I../../../include   -D_REENTRANT -fPIC
-Wall -pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings
-Wtype-limits -Wpointer-arith  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables  -o menu.o menu.c
{standard input}: Assembler messages:
{standard input}:7531: Warning: end of file not at end of a line; newline inserted
{standard input}:8093: Error: unknown pseudo-op: `.lbb11'
gcc: Internal error: Szegmens hiba (program cc1)
Please submit a full bug report.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
make[2]: *** [menu.o] Error 1
make[2]: Leaving directory
`/home/zozo/rpmbuild/BUILD/wine-1.0-rc1/dlls/user32/tests'
make[1]: *** [user32/tests] Error 2
make[1]: Leaving directory `/home/zozo/rpmbuild/BUILD/wine-1.0-rc1/dlls'
make: *** [dlls] Error 2

Version-Release number of selected component (if applicable):

$ rpm -q gcc binutils
gcc-4.3.0-8.x86_64
binutils-2.18.50.0.6-2.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. setarch i386 rpmbuild -ba --target i386 wine.spec 
2. wait...
3.
  
Actual results:

Compilation error.

Expected results:

Successful compilation.


Additional info:
Comment 1 Jakub Jelinek 2008-05-20 12:28:45 EDT

*** This bug has been marked as a duplicate of 440139 ***

Note You need to log in before you can comment on or make changes to this bug.