Bug 447614 - Lack of manpages
Lack of manpages
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
7.1
All Linux
low Severity low
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks: FDS112 639035
  Show dependency treegraph
 
Reported: 2008-05-20 16:09 EDT by Michele Baldessari
Modified: 2015-12-07 11:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:34:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Manpages in dpatch form (47.50 KB, patch)
2008-05-20 16:09 EDT, Michele Baldessari
no flags Details | Diff
cleaned up diffs (2.74 KB, patch)
2008-07-14 19:47 EDT, Rich Megginson
no flags Details | Diff
cvs commit log (3.89 KB, text/plain)
2008-07-15 11:53 EDT, Rich Megginson
no flags Details

  None (edit)
Description Michele Baldessari 2008-05-20 16:09:41 EDT
All the binaries in fedora-ds-base lack manpages.
I've given an initial goal at making them (they could use some review, as with
some tools it's hard to understand what they do at all, i.e. migratecred)

Anyways, here they are ;)

ciao,
Michele
Comment 1 Michele Baldessari 2008-05-20 16:09:41 EDT
Created attachment 306171 [details]
Manpages in dpatch form
Comment 2 Rich Megginson 2008-06-25 11:00:58 EDT
This is great!  I will need to get a CLA in order to accept these files and
patches into Fedora DS - see http://directory.fedoraproject.org/wiki/Contributing
Comment 3 Michele Baldessari 2008-06-27 11:16:41 EDT
Hi Rich,

I've just sent a signed mail to fedora-legal with the CLA pdf with my signature. My key is signed by a 
dozen people, so I hope it's enough proof of identity.

Let me know if you need anything else.

regards,
Michele
Comment 4 Rich Megginson 2008-06-30 10:51:49 EDT
The Fedora Docs Team uses OPL for everything they do:

https://fedoraproject.org/wiki/DocsProject#Documentation_Licensing

https://fedoraproject.org/wiki/DocsProject/Licensing/FAQ

Since this is for the Fedora Directory Server, I'm going to use OPL for the man
pages as well.
Comment 5 Michele Baldessari 2008-06-30 13:33:36 EDT
Hi Rich,

no problem on my side. Feel free to change the license. Let me know if you need anything else.

ciao,
Michele
Comment 6 Rich Megginson 2008-07-14 19:47:38 EDT
Created attachment 311789 [details]
cleaned up diffs
Comment 7 Rich Megginson 2008-07-15 11:53:45 EDT
Created attachment 311850 [details]
cvs commit log

Reviewed by: nhosoi (Thanks!)
Branch: HEAD
Fix Description: This adds man pages for the command line utilities.  The
configure.ac diffs were a little bit tricky - apparently, mandir is not set to
a correct default value, so we have to make sure we set a reasonable default
value it if the user has not set it (e.g. rpmbuild will override it with
--mandir=something).
Platforms tested: Fedora 8, Fedora 9
Flag Day: no
Doc impact: no

Note You need to log in before you can comment on or make changes to this bug.