Bug 447619 - Recursive obsoletes causes yum traceback
Recursive obsoletes causes yum traceback
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 16:33 EDT by Jesse Keating
Modified: 2014-01-21 18:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:44:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file showing the traceback (180.47 KB, text/plain)
2008-05-20 16:33 EDT, Jesse Keating
no flags Details

  None (edit)
Description Jesse Keating 2008-05-20 16:33:40 EDT
We get this when generating a Fedora 10 buildroot and installing the builddeps
for vbe tool.

DEBUG backend.py:490:  /usr/bin/yum --installroot
/var/lib/mock/dist-f10-build-192855-33704/root/  resolvedep  'zlib-devel'
'pciutils-devel' 'libx86-devel'
DEBUG util.py:272:  Executing command: /usr/bin/yum --installroot
/var/lib/mock/dist-f10-build-192855-33704/root/  resolvedep  'zlib-devel'
'pciutils-devel' 'libx86-devel'
DEBUG util.py:250:  0:zlib-devel-1.2.3-18.fc9.x86_64
DEBUG util.py:250:  0:pciutils-devel-2.2.10-1.fc9.x86_64
DEBUG util.py:250:  0:libx86-devel-1.1-1.fc10.x86_64
DEBUG backend.py:490:  /usr/bin/yum --installroot
/var/lib/mock/dist-f10-build-192855-33704/root/  install  'zlib-devel'
'pciutils-devel' 'libx86-devel'
DEBUG util.py:272:  Executing command: /usr/bin/yum --installroot
/var/lib/mock/dist-f10-build-192855-33704/root/  install  'zlib-devel'
'pciutils-devel' 'libx86-devel'
DEBUG util.py:250:  Traceback (most recent call last):
DEBUG util.py:250:    File "/usr/bin/yum", line 29, in ?
DEBUG util.py:250:      yummain.main(sys.argv[1:])
DEBUG util.py:250:    File "/usr/share/yum-cli/yummain.py", line 105, in main
DEBUG util.py:250:      result, resultmsgs = base.doCommands()
DEBUG util.py:250:    File "/usr/share/yum-cli/cli.py", line 293, in doCommands
DEBUG util.py:250:      return
self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
DEBUG util.py:250:    File "/usr/share/yum-cli/yumcommands.py", line 147, in
doCommand
DEBUG util.py:250:      return base.installPkgs(extcmds)
DEBUG util.py:250:    File "/usr/share/yum-cli/cli.py", line 575, in installPkgs
DEBUG util.py:250:      self.install(po)
DEBUG util.py:250:    File "/usr/lib/python2.4/site-packages/yum/__init__.py",
line 1958, in install
DEBUG util.py:250:      self.install(po=obsoleting_pkg)
DEBUG util.py:250:    File "/usr/lib/python2.4/site-packages/yum/__init__.py",
line 1958, in install
DEBUG util.py:250:      self.install(po=obsoleting_pkg)
DEBUG util.py:250:    File "/usr/lib/python2.4/site-packages/yum/__init__.py",
line 1958, in install
DEBUG util.py:250:      self.install(po=obsoleting_pkg)
DEBUG util.py:250:    File "/usr/lib/python2.4/site-packages/yum/__init__.py",
line 1958, in install
DEBUG util.py:250:      self.install(po=obsoleting_pkg)
<snip>
DEBUG util.py:250:    File "/usr/lib/python2.4/site-packages/yum/__init__.py",
line 1957, in install
DEBUG util.py:250:      obsoleting_pkg = self.getPackageObject(obsoleting)
DEBUG util.py:250:    File "/usr/lib/python2.4/site-packages/yum/__init__.py",
line 1666, in getPackageObject
DEBUG util.py:250:      pkgs = self.pkgSack.searchPkgTuple(pkgtup)
DEBUG util.py:250:    File
"/usr/lib/python2.4/site-packages/yum/packageSack.py", line 70, in searchPkgTuple
DEBUG util.py:250:      return self.searchNevra(name=n, arch=a, epoch=e, ver=v,
rel=r)
DEBUG util.py:250:    File
"/usr/lib/python2.4/site-packages/yum/packageSack.py", line 251, in searchNevra
DEBUG util.py:250:      return self._computeAggregateListResult("searchNevra",
name, epoch, ver, rel, arch)
DEBUG util.py:250:    File
"/usr/lib/python2.4/site-packages/yum/packageSack.py", line 399, in
_computeAggregateListResult
DEBUG util.py:250:      sackResult = apply(method, args)
DEBUG util.py:250:    File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py",
line 40, in newFunc
DEBUG util.py:250:      return func(*args, **kwargs)
DEBUG util.py:250:    File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py",
line 840, in searchNevra
DEBUG util.py:250:      cur = cache.cursor()
DEBUG util.py:250:    File "/usr/lib64/python2.4/site-packages/sqlite/main.py",
line 566, in cursor
DEBUG util.py:250:      return Cursor(self, self.rowclass)
DEBUG util.py:250:    File "/usr/lib64/python2.4/site-packages/sqlite/main.py",
line 172, in __init__
DEBUG util.py:250:      self.con.cursors[id(self)] = self
DEBUG util.py:250:    File "/usr/lib64/python2.4/weakref.py", line 78, in
__setitem__
DEBUG util.py:250:      self.data[key] = KeyedRef(value, self._remove, key)
DEBUG util.py:250:  RuntimeError: maximum recursion depth exceeded


This came from the attached root.log.
Comment 1 Jesse Keating 2008-05-20 16:33:40 EDT
Created attachment 306181 [details]
Log file showing the traceback
Comment 2 Seth Vidal 2008-05-20 16:45:05 EDT
libx86-devel has:
rpm -qp --obsoletes libx86-devel-1.1-2.fc10.i386.rpm 
libx86-devel <= 1.1-2.fc10

That's probably wrong.
Comment 3 Jesse Keating 2008-05-20 16:59:28 EDT
Yeah, I totally expected it to be a packaging problem triggering this, however I
do think that yum should gracefully fail here rather than 400 lines of traceback.
Comment 4 James Antill 2008-05-20 17:11:20 EDT
 I agree, but I'm sure we've fixed this since 3.2.8 ... so it should just
disappear in 5.3.
 If you want it fixed before then, it basically means adding it to
RHBA-2008:0487-02 ... but I don't think it's that important, is it?
Comment 5 Jesse Keating 2008-05-20 17:51:10 EDT
Probably not.  I think we can safely update the Fedora builders to the yum that
will be in 5.2.
Comment 6 Jesse Keating 2008-05-20 17:54:15 EDT
I just realized that we /are/ using what is close to the 5.2 package, so we'd
have to pull an early release of what will be in 5.3.  Until then when this
comes up we'll get the odd tracebacks, which I suppose one can live with...
Comment 7 James Antill 2008-09-26 16:57:22 EDT
This is fixed in the 5.3 candidate errata.
Comment 13 errata-xmlrpc 2009-01-20 16:44:40 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0176.html

Note You need to log in before you can comment on or make changes to this bug.