Bug 447620 - NetworkManager incorrectly ask for new credentials.
NetworkManager incorrectly ask for new credentials.
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 449215
  Show dependency treegraph
 
Reported: 2008-05-20 16:36 EDT by Alexey Kuznetsov
Modified: 2009-04-09 15:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 15:05:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Kuznetsov 2008-05-20 16:36:28 EDT
On week wifi connection NetworkManager incorrectly reask for credetionals. In
any case that is wifi driver limitation or networkmanager better to hardcode
that feature for use old credetionals and auto retry then show window. That
realy problem for standalone wifi notebook, when i need come to another room to
press connect button again.

here is log:

May 21 00:26:45 home-laptop NetworkManager: <info>  Activation (eth1) Stage 1 of
5 (Device Prepare) complete.
May 21 00:26:45 home-laptop NetworkManager: <info>  Activation (eth1) Stage 2 of
5 (Device Configure) starting...
May 21 00:26:45 home-laptop NetworkManager: <info>  (eth1): device state change:
4 -> 5
May 21 00:26:45 home-laptop NetworkManager: <info>  Activation (eth1/wireless):
connection 'Auto wifi.tax.local' has security, and secrets exist.  No new
secrets needed.
May 21 00:26:45 home-laptop NetworkManager: <info>  Config: added 'ssid' value
'wifi.tax.local'
May 21 00:26:45 home-laptop NetworkManager: <info>  Config: added 'scan_ssid'
value '1'
May 21 00:26:45 home-laptop NetworkManager: <info>  Config: added 'key_mgmt'
value 'WPA-PSK'
May 21 00:26:45 home-laptop NetworkManager: <info>  Config: added 'psk' value
'<omitted>'
May 21 00:26:45 home-laptop NetworkManager: <info>  Config: added 'proto' value
'WPA RSN'
May 21 00:26:45 home-laptop NetworkManager: <info>  Config: added 'pairwise'
value 'TKIP CCMP'
May 21 00:26:45 home-laptop NetworkManager: <info>  Config: added 'group' value
'WEP40 WEP104 TKIP CCMP'
May 21 00:26:45 home-laptop NetworkManager: <info>  Activation (eth1) Stage 2 of
5 (Device Configure) complete.
May 21 00:26:45 home-laptop NetworkManager: <info>  Config: set interface
ap_scan to 1
May 21 00:26:45 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 0 -> 2
May 21 00:26:45 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 2 -> 3
May 21 00:26:46 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 3 -> 4
May 21 00:26:47 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 4 -> 5
May 21 00:26:49 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 5 -> 0
May 21 00:26:49 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 0 -> 2
May 21 00:26:50 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 2 -> 3
May 21 00:27:04 home-laptop NetworkManager: <info>  eth1: link timed out.
May 21 00:27:05 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 3 -> 0
May 21 00:27:05 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 0 -> 2
May 21 00:27:06 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 2 -> 3
May 21 00:27:10 home-laptop NetworkManager: <info>  Activation (eth1/wireless):
association took too long.
May 21 00:27:10 home-laptop NetworkManager: <info>  (eth1): device state change:
5 -> 6
May 21 00:27:10 home-laptop NetworkManager: <info>  Activation (eth1/wireless):
asking for new secrets
May 21 00:27:10 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 3 -> 0
May 21 00:27:13 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 0 -> 4
May 21 00:27:13 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 4 -> 0
May 21 00:27:14 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 0 -> 2
May 21 00:27:21 home-laptop NetworkManager: <info>  (eth1): supplicant
connection state change: 2 -> 0
Comment 1 Pavel Polischouk 2008-05-28 22:37:10 EDT
Additional info:

The same happens to me.
With the weak connection, nm sometimes opens 2-3 dialogs asking to press the
'Connect' button. Sometimes the last one is the standard dialog for creating new
wireless connection (authentication fields not filled in).

Once the network is configured and connection happened at least once, NM should
mark the setup as "good" and continue trying to re-establish connection
indefinitely, and only notify the user for manual action via a change in the
status icon (attempting connection, error detected, etc.) Asking the user to
re-connect manually every time is disruptive interface behavior.

I propose changing the severity to "medium".
Comment 2 Niels Haase 2009-04-08 16:13:47 EDT
Reporter, are you still running Fedora 9, or have you upgraded to Fedora 10 or
Rawhide? In either case, can you let us know whether the issue is still happening, and give the current version of the kernel and NM packages you're
using. Thank you.


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Alexey Kuznetsov 2009-04-09 01:21:12 EDT
I put my wifi access point in middle between two rooms and problem gone. Please ask pavel.polischouk@gmail.com.

Note You need to log in before you can comment on or make changes to this bug.