Bug 447634 - mailx isn't what it seems to be
mailx isn't what it seems to be
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mailx (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 17:51 EDT by Mads Kiilerich
Modified: 2008-11-05 11:23 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-11 08:44:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2008-05-20 17:51:09 EDT
mailx package contains /bin/mail and /usr/bin/Mail and their man pages, but no
mailx.

The mailx package name indicates that installing it provides the mailx binary,
but the actual /bin/mailx command can be found in redhat-lsb (as symlink to
/bin/mail).

And even though mail and Mail and mailx ends up being the same command then
mailx has its own manpage - which can be found in the man-pages package.

This is quite confusing and time-wasting when debugging mailx problems. I
suggest that mailx should be selfcontained in Fedora 10 - or at least that
status quo and its rationale be documented in the mailx package.

Version-Release number of selected component (if applicable):
mailx-8.1.1-48.fc9.i386
Comment 1 Ivana Varekova 2008-06-11 08:44:55 EDT
This seems to be ok - mail(1) is an man-page which is a part of mailx package
and contains the description of mail command which is its part too. mailx(1p) is
a part of  man-pages and describe the the posix standard. mailx binary is the
part of redhat-lsb.
Comment 2 Mads Kiilerich 2008-11-05 11:23:38 EST
For the record,

* Wed Jul 30 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 12.3-1
- Place mailx to /bin/mailx, to avoid extra symlink in redhat-lsb package
- /bin/mailx is now a base binary, another symlinked to it.

thanks

Note You need to log in before you can comment on or make changes to this bug.