Bug 447638 - SELinux prevented umount from mounting on the file or directory "/media/.hal-mtab-lock" (type "mnt_t").
SELinux prevented umount from mounting on the file or directory "/media/.hal-...
Status: CLOSED DUPLICATE of bug 447195
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 17:56 EDT by Martin Naď
Modified: 2008-05-20 18:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-20 18:10:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Naď 2008-05-20 17:56:14 EDT
Description of problem:
SELinux prevented umount from mounting a filesystem on the file or directory "/
media/.hal-mtab-lock" of type "mnt_t". By default SELinux limits the mounting 
of filesystems to only some files or directories (those with types that have 
the mountpoint attribute). The type "mnt_t" does not have this attribute. You 
can either relabel the file or directory or set the boolean 
"allow_mount_anyfile" to true to allow mounting on any file or directory. 

host=localhost.localdomain type=AVC msg=audit(1211325298.228:87): avc: denied 
{ read write } for pid=6922 comm="umount" path="/media/.hal-mtab-lock" dev=sda2 
ino=89763 scontext=system_u:system_r:mount_t:s0 
tcontext=system_u:object_r:mnt_t:s0 tclass=file 

host=localhost.localdomain type=SYSCALL msg=audit(1211325298.228:87): 
arch=c000003e syscall=59 success=yes exit=0 a0=403665 a1=7fff60c6c6b0 
a2=7fff60c6cd38 a3=7fff60c6c060 items=0 ppid=6921 pid=6922 auid=4294967295 
uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) 
ses=4294967295 comm="umount" exe="/bin/umount" 
subj=system_u:system_r:mount_t:s0 key=(null) 

Version-Release number of selected component (if applicable):
selinux-policy-3.3.1-51.fc9.noarch


How reproducible:
nearly always

Steps to Reproduce:
1.mount cd
2.press the eject button on the dvd-rom drive
  
Actual results:
I have to press the button several times (4 times or even more) before the DVD 
is ejected
But immediately after the first press of the button an AVC denial shows up

Expected results:
No AVC denial should be generated and the DVD should be ejected after a single 
press of the button

Additional info:
Comment 1 Martin Naď 2008-05-20 18:10:30 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=447195

*** This bug has been marked as a duplicate of 447195 ***

Note You need to log in before you can comment on or make changes to this bug.