Bug 447663 - RFE: Let the users set the timezone for them!
RFE: Let the users set the timezone for them!
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.2
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 21:45 EDT by Milos Jakubicek
Modified: 2013-06-24 00:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-09 09:38:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 182238 None None None Never

  None (edit)
Description Milos Jakubicek 2008-05-20 21:45:21 EDT
Description of problem:

It would be very helpful, if the user could set in his preferences the timezone
which would be used to display proper time (in bugreports, comments etc). I
think it shouldn't take much time to implement this, but if it would be the
case, even having UTC instead of PDT/EST/anything would be nice.
Comment 1 Till Maas 2008-05-22 10:11:53 EDT
Having UTC as the default timezone would be great.
Comment 2 David Lawrence 2008-05-23 18:17:26 EDT
We are using upstream 3.2 code for our beta (with some RH customizations) so
this should really be fixed upstream and then we can apply the changes here.

Currently being discussed here:
https://bugzilla.mozilla.org/show_bug.cgi?id=182238

If we (RH) have resources we may be able to help but this is low priority until
the rest of our blockers are done.

Dave

Comment 3 Till Maas 2008-05-23 18:31:54 EDT
(In reply to comment #2)
> We are using upstream 3.2 code for our beta (with some RH customizations) so
> this should really be fixed upstream and then we can apply the changes here.

Is it possible to run the bugzilla server with UTC as its timezone? Afaik this
is what all Fedora servers currently do and it would not require changes in the
Bugzilla code I guess.
Comment 4 David Lawrence 2008-08-18 18:12:47 EDT
FWIW, there is support being worked on upstream to dynamically display the time in the time zone preferred by the user.

https://bugzilla.mozilla.org/show_bug.cgi?id=182238

We will help out with testing this feature.
Comment 5 David Lawrence 2008-08-22 12:27:17 EDT
I am currently reviewing the patch created by upstream to provide this feature. Hopefully we will have it in near future update. Just figuring out the perl dependencies for this currently.

https://bugzilla.mozilla.org/attachment.cgi?id=334348

Dave
Comment 6 Milos Jakubicek 2009-03-14 19:28:24 EDT
Well...how does it look? The Mozilla bug is resolved...would be really nice to include the changes into RH bugzilla -- thanks in advance!
Comment 7 David Lawrence 2009-03-15 21:10:38 EDT
(In reply to comment #6)
> Well...how does it look? The Mozilla bug is resolved...would be really nice to
> include the changes into RH bugzilla -- thanks in advance!  

The feature is part if the upcoming 3.4 release and would require significant work to backport to 3.2. 
As we will be moving to the next release shortly after it is released we will also inherit that feature as well. 

Dave
Comment 8 Petr Šplíchal 2009-10-27 04:26:03 EDT
Looking forward to having the time zone option available! This
will definitely be very useful & welcomed feature.

What's the current status on this? In other words: What does it
mean "we will be moving to the next release shortly after it is
released"? The upstream 3.4 version is available since July:

http://www.bugzilla.org/news/#release34

Thank you for looking into this.
Comment 9 David Lawrence 2009-10-27 10:32:27 EDT
We are slated to update to 3.4 before the end of the year. It has taken longer than expected due to other projects that the BZ team members work on in addition to BZ. 3.4 will as you mentioned have this new functionality.

Dave
Comment 10 Milos Jakubicek 2010-01-09 09:38:49 EST
I'm glad to close this bugreport since RHBZ 3.4 has been installed today and solves this problem. Thanks for working on this!

Note You need to log in before you can comment on or make changes to this bug.