Bug 447675 - Can't add/remove repositories or software packages.
Can't add/remove repositories or software packages.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 00:30 EDT by John Dvoracek
Modified: 2008-05-21 15:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 15:34:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Dvoracek 2008-05-21 00:30:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
System>Administration>Software Sources will not let me check or uncheck any of the repositories (yes I am root).

System>Administration>Add/Remove Software will let me find and select packages but nothing happens when I click install.  However, I can go to the terminal window and yum install those packages without problems.

If you tell me this is the wrong place to report this, please also tell me where I should have and how I should have found that out.

Version-Release number of selected component (if applicable):
2.6.25.3-18.fc9.i686  gpk-repo gpk-application

How reproducible:
Always


Steps to Reproduce:
1. No special setup - see description above.
2.
3.

Actual Results:
Nothing happens.

Expected Results:
See description.

Additional info:
This is a severe bug in that I can't add packages I need to do what I need to do.
Comment 1 Jesse Keating 2008-05-21 09:38:07 EDT
Since you know it's gpk-repo that is giving you the problem, you can use:

rpm -qfi /usr/bin/gpk-repo

You'll note in the output that it comes from the 'gnome-packagekit' source rpm.
 Thus the component this should be filed against is 'gnome-packagekit'.
Comment 2 John Dvoracek 2008-05-21 13:28:32 EDT
Thanks!  I see you have updated this report to point to the correct package.  I
just updated my system, and the bug persists.

BTW, I didn't know I had to specify the full path to gpk-repo which is why I
couldn't find the correct component:

[root@T23 ~]# rpm -qfi gpk-repo
error: file /root/gpk-repo: No such file or directory
Comment 3 Richard Hughes 2008-05-21 15:34:09 EDT
Please see http://fedoraproject.org/wiki/PackageKitFaq

Note You need to log in before you can comment on or make changes to this bug.