Bug 447679 - RFE: Support multiple livecd images on usb pen
RFE: Support multiple livecd images on usb pen
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 01:10 EDT by Pedro Silva
Modified: 2008-05-29 16:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-29 16:35:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Silva 2008-05-21 01:10:20 EDT
Description of problem:

USB pen drives are getting bigger. One could fit many livecd created images in a
pen and choose which one to boot from grub. Major changes would be required in
livecd-iso-to-disk is my best guess. A usb pen could carry Fedora livecd
flavours (Gnome/KDE/Games) and some custom made images made with kickstart files.

Persistance with multiple images is something I haven't think of or maybe just
no Persistance at all.

Comments? Flames? Nonsense?
Comment 1 Jeremy Katz 2008-05-21 09:21:22 EDT
The bigger changes needed would really be in the initrd where we hard-code
looking for the files under LiveOS with specific filenames.  It's fairly doable,
the question is just if it's worth the maintenance headache and added complexity
over the simple solution we currently have.
Comment 2 Pedro Silva 2008-05-21 11:58:33 EDT
Thank you for your input on this idea, although I'm not a coder, I understand
the burden. I really like the entire livecd-tools stuff, I've been playing with
these new toys since fedora 8.

More feedback on this RFE by anyone is welcome.
Comment 3 Jeremy Katz 2008-05-29 16:35:22 EDT
I think that at the moment, I'm going to defer this.  If someone is interested
in doing some of the work, I'd be glad to help them go in the right direction,
but it's not something that I'm going to have time to do in the next release
cycle or so

Note You need to log in before you can comment on or make changes to this bug.