Bug 447691 - unable to partly pre-fill form with an HTTP PUT to query cgi
unable to partly pre-fill form with an HTTP PUT to query cgi
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.2
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks: RHBZ30UpgradeTracker
  Show dependency treegraph
 
Reported: 2008-05-21 03:02 EDT by Zing
Modified: 2013-06-23 22:14 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-22 16:11:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zing 2008-05-21 03:02:20 EDT
Description of problem:
I'll often use bugzilla as follows:

https://partner-bugzilla.redhat.com/query.cgi?format=advanced&classification=Fedora&product=Fedora&component=a2ps

to "pre-fill" the query form with the component already selected.  This doesn't
seem to work in the beta 3.2 site.

it's a bit weird when the screen renders, because it first looks like the proper
fields are actually selected, but then the menus "blank/grey" out and I'm only
left with the classification and product highlighted.

Version-Release number of selected component (if applicable):
Bugzilla 3.2 Beta Test Site
My Browser: seamonkey-1.1.9-4.fc9.x86_64

How reproducible:
all the time

Steps to Reproduce:
1. click on the link above
  
Actual results:
component not selected

Expected results:
component selected

Additional Info:
I do the same thing for enter_bug.cgi, but I haven't tested that to see if that
works.
Comment 1 Noura El hawary 2008-05-22 01:53:44 EDT
Yes you are right about query.cgi I guess it is the order of executing ajax that
is causing the problem. enter_bug.cgi however works fine

Noura
Comment 2 David Lawrence 2008-07-10 18:02:28 EDT
Will show up on partner-bugzilla.redhat.com on the next beta update for
verification.
Comment 3 David Lawrence 2008-07-14 18:21:20 EDT
Reverting change as it doesn't fix the issue.
Comment 4 David Lawrence 2008-07-17 12:37:07 EDT
Finally fixed this proper and commit to CVS. Will show up in the next update to
partner-bugzilla.redhat.com.
Comment 5 David Lawrence 2008-07-22 16:11:06 EDT
The changes have been pushed to partner-bugzilla.redhat.com and/or have been
recorded in the Bugzilla migration pages on the Bugzilla 3 upgrade Wiki.

Closing as NEXTRELEASE.
Dave

Note You need to log in before you can comment on or make changes to this bug.