Bug 447696 - synergys often stops with segmentation fault
synergys often stops with segmentation fault
Status: CLOSED DUPLICATE of bug 434539
Product: Fedora
Classification: Fedora
Component: synergy (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 03:53 EDT by Max Rydahl Andersen
Modified: 2008-05-30 12:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 12:10:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Rydahl Andersen 2008-05-21 03:53:23 EDT
Description of problem:
I'm running synergys on my 64bit F9 against a Mac Leopard and Windows as synergy
clients. It works ok, but synergys keep segfaulting with no real apparent
pattern when it happens.

It happens multiple times per hour.

Version-Release number of selected component (if applicable):
INFO: synergys.cpp,1042: Synergy server 1.3.1 on Linux 2.6.25.3-18.fc9.x86_64 #1

How reproducible:
Always, at last in my setup.

Steps to Reproduce:
1. Run synergys with multiple clients
2. Work 
3. ....
4. Segmentation fault!
  
Actual results:
Segmentation fault

Expected results:
No segmentation fault
Comment 1 Kazuo Moriwaka 2008-05-30 04:22:18 EDT
In i386 env, synergys segfaults too.
I feel it causes when I copy(copy&paste's copy) something into buffer.

dmesg shows following messages:

synergys[3688]: segfault at c ip 002c6296 sp bfe0c294 error 4 in
libstdc++.so.6.0.10[26c000+e5000]
synergys[8905]: segfault at c ip 002c6296 sp bfaf0774 error 4 in
libstdc++.so.6.0.10[26c000+e5000]
Comment 2 Matthias Saou 2008-05-30 12:10:38 EDT

*** This bug has been marked as a duplicate of 434539 ***

Note You need to log in before you can comment on or make changes to this bug.