Bug 447707 - Circular obsoletes with the new renamed openib-* packages
Circular obsoletes with the new renamed openib-* packages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openib (Show other bugs)
4.7
All Linux
low Severity high
: beta
: ---
Assigned To: Doug Ledford
Alexander Todorov
:
Depends On:
Blocks: RHEL4u7_relnotes 448143
  Show dependency treegraph
 
Reported: 2008-05-21 05:53 EDT by Alexander Todorov
Modified: 2009-05-07 09:52 EDT (History)
7 users (show)

See Also:
Fixed In Version: RHEA-2008-0737
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:59:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Possible change to up2date to handle a special case (3.06 KB, patch)
2008-05-22 17:03 EDT, John Matthews
no flags Details | Diff

  None (edit)
Description Alexander Todorov 2008-05-21 05:53:55 EDT
Description of problem:
There are circular obsoletes with newer openib-* packages. The packages changed
names between RHEL4-U6 and RHEL4-U7 and the old package obsoletes the new name
and vice versa. 

Version-Release number of selected component (if applicable):
mstflint-1.3-1.el4
perftest-1.2-11.el4
tvflash-0.9.0-2.el4


How reproducible:
always

Steps to Reproduce:
rpm -qp --obsoletes $old_package
rpm -qp --obsoletes $new_package
  
Actual results:
circular obsoletes. package upgrade fails.

Expected results:
package upgrade works.

Additional info:
OLD openib-mstflint-1.2-7.x86_64.rpm obsoletes mstflint but NEW
mstflint-1.3-1.el4.x86_64.rpm obsoletes openib-mstflint  
OLD openib-perftest-1.2-7.x86_64.rpm obsoletes perftest but NEW
perftest-1.2-11.el4.x86_64.rpm obsoletes openib-perftest  
OLD openib-tvflash-0.9.2-7.x86_64.rpm obsoletes tvflash but NEW
tvflash-0.9.0-2.el4.x86_64.rpm obsoletes openib-tvflash
Comment 1 Alexander Todorov 2008-05-21 05:55:47 EDT
This bug is the cause for bug #447333 and much likely the fixes need to go into
the package's spec file and not up2date
Comment 10 Don Domingo 2008-05-22 19:48:31 EDT
thanks Alex, adding the following to RHEL4.7 release notes under "known issues":

<quote>
The following packages have changed their names in this release:

    * openib-perftest
    * openib-tvflash
    * openib-mstflint

These packages no longer have the name prefix openib-. The change in naming
convention may cause upgrades via Red Hat Network to fail.

To prevent this from occurring, remove the old versions of these packages before
performing an upgrade.
</quote>

please advise if any further revisions are required. thanks!
Comment 18 Philippe Brieu 2008-05-28 13:03:51 EDT
This also affects RHEL 5.2 Client.  In addition, when all packages are selected
for installation, Anaconda crashes while processing dependencies, making the
installation of RHEL impossible!  Should a separate bug be opened for that?
Comment 19 James Laska 2008-05-28 13:18:00 EDT
philippe+bugzilla@caltech.edu: Please open a separate bug against the Red Hat
Enterprise Linux 5 product.
Comment 20 Aaron Henderson 2008-05-28 15:36:08 EDT
Bugzilla 448772 - https://bugzilla.redhat.com/show_bug.cgi?id=448772 has been
open for this issue for RHEL 5.2 by (philippe+bugzilla@caltech.edu)
Comment 22 Don Domingo 2008-06-02 18:25:12 EDT
thanks Alexander. removing release note. 
Comment 23 Don Domingo 2008-06-02 19:16:16 EDT
Hi,

the RHEL4.7 release notes deadline is on June 17, 2008 (Tuesday). they will
undergo a final proofread before being dropped to translation, at which point no
further additions or revisions will be entertained.

a mockup of the RHEL4.7 release notes can be viewed here:
http://intranet.corp.redhat.com/ic/intranet/RHEL4u7relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don
Comment 25 errata-xmlrpc 2008-07-24 15:59:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0737.html

Note You need to log in before you can comment on or make changes to this bug.