Bug 447715 - gdm should use .UTF-8 for locale encoding not .utf8
gdm should use .UTF-8 for locale encoding not .utf8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-05-21 06:34 EDT by Ilya
Modified: 2015-01-14 18:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-26 03:23:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdm-2.23.92-utf8.patch (1.39 KB, patch)
2008-09-17 03:09 EDT, Jens Petersen
no flags Details | Diff

  None (edit)
Description Ilya 2008-05-21 06:34:19 EDT
Fedora uses for Russian language incorrect local "ru_RU.utf8" which is 
incorrect, it should be "ru_RU.UTF-8". Because of this, Russian characters 
cannot be entered in any application under Wine. Probably other localizations 
affected too.

See also http://bugs.winehq.org/show_bug.cgi?id=13318

If an application under Wine started with explicite locale (i.e. LANG=ru_RU.UTF-
8 wine notepad), all works properly in the application.
Comment 1 Jens Petersen 2008-05-23 03:20:49 EDT
(In reply to comment #0)
> Fedora uses for Russian language incorrect local "ru_RU.utf8" which is 
> incorrect, it should be "ru_RU.UTF-8".

This is not true: at least I cannot reproduce this.
I am not sure how you are getting .utf8?
When I tried now on my F9 machine system-config-language
correctly sets the locale to ru_RU.UTF-8.

What is the content of your /etc/sysconfig/i18n file?
Can you reproduce for a new user?  I suspect you may
have some user configuration overriding the locale setting perhaps?
Comment 2 Ilya 2008-05-24 19:09:41 EDT
Because of well-known bug with Russian installer I installed the system in
English and then switched to Russian locale with system-config-language.

/etc/sysconfig/i18n:

LANG="ru_RU.UTF-8"
SYSFONT="latarcyrheb-sun16"

[nxx@fedora-pc ~]$ locale
LANG=ru_RU.utf8
LC_CTYPE="ru_RU.utf8"
LC_NUMERIC="ru_RU.utf8"
LC_TIME="ru_RU.utf8"
LC_COLLATE="ru_RU.utf8"
LC_MONETARY="ru_RU.utf8"
LC_MESSAGES="ru_RU.utf8"
LC_PAPER="ru_RU.utf8"
LC_NAME="ru_RU.utf8"
LC_ADDRESS="ru_RU.utf8"
LC_TELEPHONE="ru_RU.utf8"
LC_MEASUREMENT="ru_RU.utf8"
LC_IDENTIFICATION="ru_RU.utf8"
LC_ALL=

Comment 3 Jens Petersen 2008-07-23 01:46:43 EDT
(In reply to comment #2)
> Because of well-known bug with Russian installer I installed the system in
> English and then switched to Russian locale with system-config-language.

Do you have more details about that?  We should try to check that.

> /etc/sysconfig/i18n:
> LANG="ru_RU.UTF-8"
> [nxx@fedora-pc ~]$ locale
> LANG=ru_RU.utf8

Do you have any locale settings in .i18n or shell config files?

Can you answer:

(In reply to comment #1)
> Can you reproduce for a new user?  I suspect you may
> have some user configuration overriding the locale setting perhaps?

Comment 4 Tony Fu 2008-09-09 23:10:02 EDT
requested by Jens Petersen (#27995)
Comment 5 Jens Petersen 2008-09-14 22:09:33 EDT
I realised this is caused by gdm.  Still happens with current rawhide too.

Look at "~/.dmrc".
Comment 6 Jens Petersen 2008-09-17 03:09:20 EDT
Created attachment 316928 [details]
gdm-2.23.92-utf8.patch

This patch seems to fix the problem at least.

But users who have set language from gdm should really be migrated from .utf8 to .UTF-8 automatically.
Comment 7 Ray Strode [halfline] 2008-09-17 09:29:18 EDT
So that patch isn't right, because it won't turn "utf8" to "UTF-8"

The point is to take all legal variations of the locale and turn it into one format so they can be compared and indexed in a hash table.
Comment 8 Ray Strode [halfline] 2008-09-17 11:46:49 EDT
This should be working better in 2.23.92-8

Can you confirm?
Comment 9 Jens Petersen 2008-09-17 23:09:12 EDT
Hmm, seems to segfault for me when displaying the language menu popup dialog.
Comment 10 Ray Strode [halfline] 2008-09-19 10:27:52 EDT
not sure if/how the crash is related to my changes, but i've fixed it in -9
Comment 11 Jens Petersen 2008-09-26 03:23:30 EDT
Thanks looks good now.
Comment 12 Jay Hilliard 2013-05-09 19:53:59 EDT
This patch is not applied to gdm 2.30.4-39 which is part of RHEL6.4
Should it be?  We are eperiencing the same issue.

Note You need to log in before you can comment on or make changes to this bug.