Bug 447724 - P35+ICH9R SEGFAULT during boot in libdevmapper.so.1.0.2; happens every time starting after F9 install completes and it is time to first-boot.
P35+ICH9R SEGFAULT during boot in libdevmapper.so.1.0.2; happens every time s...
Status: CLOSED DUPLICATE of bug 446669
Product: Fedora
Classification: Fedora
Component: device-mapper-obsolete (Show other bugs)
9
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 08:39 EDT by c.h.
Modified: 2008-05-21 10:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:10:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of crash console log + backtrace (2.44 MB, image/jpeg)
2008-05-21 08:42 EDT, c.h.
no flags Details
screen shot of grub kernel / initrd parameters which subsequently crash on boot (1.85 MB, image/jpeg)
2008-05-21 08:45 EDT, c.h.
no flags Details
screen shot of crash console log + backtrace (2nd distinct crash) (2.50 MB, image/jpeg)
2008-05-21 08:48 EDT, c.h.
no flags Details
screen shot of crash console log + backtrace (3rd distinct crash) (2.45 MB, image/jpeg)
2008-05-21 08:51 EDT, c.h.
no flags Details

  None (edit)
Description c.h. 2008-05-21 08:39:06 EDT
Description of problem:
SEGFAULT during boot in libdevmapper.so.1.0.2
Problem occurs on the first (and all subsequent) boot attempts
after a successful Fedora 9 installation onto a clean hard disk.

Version-Release number of selected component (if applicable):
libdevmapper.so.1.0.2

How reproducible:
100% on a hand-full of attempts.

Steps to Reproduce:
1.  Install Fedora 9; pick a PATA drive to fresh-install to with complete
formatting and default system suggested partition layout.  Encryption is enabled
on the system partition according to the anaconda checkbox for that.
2. Customize package selection somewhat adding in many of the optional packages.
3. System installs packages, ejects DVD, displays installation complete dialog;
reboot, get the SEGV error every time.

  
Actual results:

SEGV crash a few seconds into the boot process.

Expected results:

Successful boot.

Additional info:

System is:
* P5K Deluxe motherboard with P35 chipset + ICH9R with an added 
JMicron SATA/IDE motherboard controller chip ; 

* sde is 120GB PATA WD1200 boot drive with default layout with encryption
enabled.  The BIOS has this listed as the first/primary boot hard disc, and
there is no problem with the BIOS booting to GRUB and GRUB working to select the
GRUB configured kernel/initrd etc.  The crash occurs after GRUB proceeds to boot
the only / default kernel system which was configured by the just completed
Fedora 9 install.  At no point between GRUB and the CRASH has it asked for the
encryption password which was specified during Fedora Install using Anaconda.

* sdc has a pre-existing data partition on a 500GB drive not selected for
Fedora9 installation / mounting, though it did show up in the anaconda list of
detected drives/partitions.

* mapper/mpath0 is gnu knows what; anaconda said it had an unreadable partition
table; this was NOT selected for labeling/initialization or use during install.

* There are a total of four 500GB Maxtor SATA drives attached to motherboard
SATA ports between the ICH9R's four SATA ports and the couple of ports the
JMicron chip adds.  One of these is presumably the sdc listed above, the rest
may be lumped into mapper/mpath0 or whatever; they weren't explicitly listed in
anaconda during install.

* The following bugzilla bugs seem to show similar weaknesses / crashes on boot,
though I am posting this distinctly since my system varies somewhat from theirs
and I expect my backtrace et. al. data is potentially unique / distinct.
https://bugzilla.redhat.com/show_bug.cgi?id=446669
https://bugzilla.redhat.com/show_bug.cgi?id=431778
Comment 1 c.h. 2008-05-21 08:42:22 EDT
Created attachment 306237 [details]
screen shot of crash console log + backtrace
Comment 2 c.h. 2008-05-21 08:45:45 EDT
Created attachment 306238 [details]
screen shot of grub kernel / initrd parameters which subsequently crash on boot
Comment 3 c.h. 2008-05-21 08:48:32 EDT
Created attachment 306239 [details]
screen shot of crash console log + backtrace (2nd distinct crash)
Comment 4 c.h. 2008-05-21 08:51:18 EDT
Created attachment 306240 [details]
screen shot of crash console log + backtrace (3rd distinct crash)
Comment 5 Zdenek Kabelac 2008-05-21 10:10:29 EDT

*** This bug has been marked as a duplicate of 446669 ***

Note You need to log in before you can comment on or make changes to this bug.