Bug 447735 - Mixer channels not detected on Sony Vaio VGN-FZ31Z notebook
Mixer channels not detected on Sony Vaio VGN-FZ31Z notebook
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 10:11 EDT by Michael Donnellan
Modified: 2008-05-26 09:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-26 09:05:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Donnellan 2008-05-21 10:11:55 EDT
Description of problem:

All mixer channels are not detected, only Master and PCM. 

Version-Release number of selected component (if applicable):

kernel-2.6.25.3-18.fc9.x86_64
alsa-lib-1.0.16-3.fc9.x86_64


How reproducible:

Always
  
Actual results:

Only mixers for Master and PCM present. 

Expected results:

Full range of mixers, including input. 

Additional info:

HDA Intel sound chip, from lspci -nnvv:

00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio
Controller [8086:284b] (rev 03)
	Subsystem: Sony Corporation Vaio VGN-FZ260E [104d:9005]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping-
SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 22
	Region 0: Memory at fc400000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel

Also seen in dmesg:

ALSA sound/pci/hda/hda_intel.c:1810: chipset global capabilities = 0x4401
ALSA sound/pci/hda/hda_intel.c:749: codec_mask = 0x3
ALSA sound/pci/hda/hda_generic.c:607: AUD_IN = 6
ALSA sound/pci/hda/hda_generic.c:234: UNMUTE IN: NID=0x6 IDX=0x0
ALSA sound/pci/hda/hda_generic.c:607: AUD_IN = 8
ALSA sound/pci/hda/hda_generic.c:234: UNMUTE IN: NID=0x8 IDX=0x0
ALSA sound/pci/hda/hda_generic.c:234: UNMUTE IN: NID=0xd IDX=0x0
ALSA sound/pci/hda/hda_generic.c:249: CONNECT: NID=0x15 IDX=0x1
ALSA sound/pci/hda/hda_generic.c:234: UNMUTE IN: NID=0x15 IDX=0x1
ALSA sound/pci/hda/hda_generic.c:219: UNMUTE OUT: NID=0x15
ALSA sound/pci/hda/hda_generic.c:234: UNMUTE IN: NID=0x9 IDX=0x0
ALSA sound/pci/hda/hda_generic.c:219: UNMUTE OUT: NID=0x9
ALSA sound/pci/hda/hda_generic.c:644: [Capture Source] NID=0x8, #SRC=1
ALSA sound/pci/hda/hda_generic.c:647:   [Mic] IDX=0x0
ALSA sound/pci/hda/hda_generic.c:286: AUD_OUT found 5
ALSA sound/pci/hda/hda_generic.c:234: UNMUTE IN: NID=0xf IDX=0x0
ALSA sound/pci/hda/hda_generic.c:219: UNMUTE OUT: NID=0xf
ALSA sound/pci/hda/hda_generic.c:219: UNMUTE OUT: NID=0xf
ALSA sound/pci/hda/hda_generic.c:286: AUD_OUT found 2
ALSA sound/pci/hda/hda_generic.c:249: CONNECT: NID=0x8 IDX=0x0
ALSA sound/pci/hda/hda_generic.c:733: [Master Playback Switch] NID=0x5, DIR=OUT
ALSA sound/pci/hda/hda_generic.c:753: [Master Playback Volume] NID=0x5, DIR=OUT
Comment 1 Martin Stransky 2008-05-26 09:04:14 EDT
Those mixer slides are not propagated and they're covered by pulse audio now.
Comment 2 Martin Stransky 2008-05-26 09:05:05 EDT
If you think it's a bug please open a bug-report against pulse audio. Closing as
WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.