Bug 447762 - Evolution giving grey blocks for preview and on emails
Evolution giving grey blocks for preview and on emails
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gtkhtml3 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Triaged
: 458209 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 13:10 EDT by Paul F. Johnson
Modified: 2009-12-18 01:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:09:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
email showing the problem - when the scroll bars are generated, the grey appears (51.42 KB, image/png)
2008-05-21 13:10 EDT, Paul F. Johnson
no flags Details
Email preview pane showing the problem. The deleted email line makes no difference (158.26 KB, image/png)
2008-05-21 13:10 EDT, Paul F. Johnson
no flags Details
new composer (354.30 KB, image/png)
2008-08-06 11:31 EDT, Matthias Clasen
no flags Details
after some editing (49.62 KB, image/png)
2008-08-06 11:33 EDT, Matthias Clasen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 546587 None None None Never
GNOME Desktop 546754 None None None Never

  None (edit)
Description Paul F. Johnson 2008-05-21 13:10:02 EDT
Description of problem:
Evolution is giving grey blocks when replying to emails (and a scroll bar is
required) as well as some emails showing as just grey on grey in the preview
pane. If an email is grey on grey in a preview pane, when hitting reply to, the
reply to is also grey on grey

Version-Release number of selected component (if applicable):
3.23.2-4.fc10

How reproducible:
Varies and doesn't appear on all emails.

Steps to Reproduce:
1. Ensure preview pane is on
2. Download email
3.
  
Actual results:
See screenshots.

Expected results:
All emails should be visible and scrollbars generated.

Additional info:
Killing evolution-data-server fixes the problem for a while
Comment 1 Paul F. Johnson 2008-05-21 13:10:02 EDT
Created attachment 306282 [details]
email showing the problem - when the scroll bars are generated, the grey appears
Comment 2 Paul F. Johnson 2008-05-21 13:10:56 EDT
Created attachment 306283 [details]
Email preview pane showing the problem. The deleted email line makes no difference
Comment 3 Matthew Barnes 2008-05-21 13:51:54 EDT
(In reply to comment #0)
> Killing evolution-data-server fixes the problem for a while

You mean killing just the evolution-data-server process, right?  As opposed to
"evolution --force-shutdown".

That strikes me as odd because the e-d-s process isn't involved in rendering or
really anything to do with email at all.  Unless addressbook lookups are
factoring into this somehow...
Comment 4 Paul F. Johnson 2008-05-21 14:48:32 EDT
killing e-d-s does it as does the force-shutdown, but not as well.
Comment 5 Paul F. Johnson 2008-05-30 06:09:37 EDT
This is still happening with evolution 2.23.2-1.fc10. Is there any way around
having to continually having to do a --force-shutdown every 6 or so emails?
Comment 6 Matthew Barnes 2008-05-30 08:02:03 EDT
I have no idea yet on this one.  I'm not seeing it at all and haven't heard of
similar reports from others.

What version of gtkhtml3 are you using?  And what desktop theme?
Comment 7 Paul F. Johnson 2008-05-30 09:23:09 EDT
gtkhtml3 - 3.23.2-4
Clearlooks theme
Comment 8 Milan Crha 2008-06-09 08:07:00 EDT
This happened to me only once, last week, As far as I can tell, the status bar
widget is also somehow strange, so I guess it's related to packing. In time it
was broken, I saw there a "Formatting message" in a preview area, but as soon as
the message was formatted, then the gray block covered all the preview area.
There was also one interesting thing, the links and clickable addresses in a
preview are worked fine. (I didn't see them, but move cursor was changing.) The
problem is it works fine next time I run Evolution.
Comment 9 Matthew Barnes 2008-06-09 08:30:23 EDT
If either of you figure out how to reproduce this consistently, please post
instructions here.  I still have not seen it for myself.
Comment 10 Paul F. Johnson 2008-07-08 14:04:20 EDT
The problem looks to be a formatting one. If everything goes grey, highlight the
lot and change from Normal in the formatting drop down to unformatted and
everything reappears.

Change back to normal and it goes grey again
Comment 11 Matthias Clasen 2008-08-06 11:31:41 EDT
Created attachment 313585 [details]
new composer

Here is what I am seeing. Initially, a new mail comes up with a big gray area that doesn't redraw properly (see the shadow that a window left there), and just a single line of white, editable area.
Comment 12 Matthias Clasen 2008-08-06 11:33:18 EDT
Created attachment 313586 [details]
after some editing

When editing, the white area expands to fill the space, but the text is repeated multiple times...
Comment 13 Matthew Barnes 2008-08-06 11:41:12 EDT
Upstream bug similar to comment #12:
http://bugzilla.gnome.org/show_bug.cgi?id=546587
Comment 14 Matthew Barnes 2008-08-06 21:01:43 EDT
*** Bug 458209 has been marked as a duplicate of this bug. ***
Comment 15 Milan Crha 2008-08-07 08:30:05 EDT
Based on the upstream bug [1] it seems like gtk+ issue.
[1] http://bugzilla.gnome.org/show_bug.cgi?id=546754

Text from there:
the evolution mail composer has rendering issues when using gtk 2.13.6 (the
text is displayed duplicated in a second column, the textview area is wrong
when opening the composer, etc), when resizing the dialog everything is
correctly displayed again so that seems a refreshing issue, using gtk 2.13.5
there is no such issues
Comment 16 Paul F. Johnson 2008-08-30 10:02:27 EDT
killing plugins solves the problem (evolution --disable-eplugin), but then that means the likes of spamassassin is dead...
Comment 17 Paul F. Johnson 2008-09-03 10:10:51 EDT
Killing eplugins and running from the command line reveals some a11y problems. I'm not sure if they're related though.

subcell_view 0x830da0 deleted before the a11y object 0xb4204780
subcell_view 0x830da0 deleted before the a11y object 0x9e38458
subcell_view 0x830da0 deleted before the a11y object 0xb4262b70
subcell_view 0x830da0 deleted before the a11y object 0xb4262470
Comment 18 John Poelstra 2008-10-15 19:18:45 EDT
This bug has been triaged
Comment 19 Bug Zapper 2008-11-25 21:19:02 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 20 Bug Zapper 2009-11-18 03:13:12 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 21 Bug Zapper 2009-12-18 01:09:55 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.