This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 447767 - gpk-application for GNOME don't resolve depencies correct during deinstallation kernel
gpk-application for GNOME don't resolve depencies correct during deinstallati...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 14:05 EDT by Marcel Berlau
Modified: 2009-06-03 05:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 05:43:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Berlau 2008-05-21 14:05:19 EDT
I want to deinstall an old kernel via the gpk-application tool. So I select the 
old kernel and klick remove.

Then gpk told me that he want due to dependencies of other packages to remove 
them. 
But in the message you can read, that these are packages which are important 
for the system like FUSE, Xorg-driver and 2 or 3 others.

And you can see that for example an webcam-driver which should be removed has 
an dependency with the actuall kernel who should stay.

So i took the terminal an write "yum remove <kernelversion>" and then yum 
remove the kernel without any warnings about dependency-problems.
Comment 1 Richard Hughes 2008-06-03 09:03:21 EDT
Sure, the problem is that we are not checking if other packages with the same
name can provide the requires. I'm not sure what the solution is here. I'll work
on a fix now.
Comment 2 Richard Hughes 2008-06-03 09:25:30 EDT
Fixed in git master, commit 9e2e8562f85f8234567dc6c6a1226e2e4e41a5ac

Do you want me to backport this for F9?
Comment 3 Marcel Berlau 2008-06-03 09:33:57 EDT
If this is possible?! I think that it is a good solution for new users, when
this will work correct in F9
Comment 4 Richard Hughes 2009-06-03 05:43:12 EDT
Not possible to backport, sorry. Too many other changes.

Note You need to log in before you can comment on or make changes to this bug.