Bug 447773 - Samba wins resolution fails
Samba wins resolution fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 14:16 EDT by kidboy14
Modified: 2008-06-09 10:44 EDT (History)
0 users

See Also:
Fixed In Version: 3.2.0-1.rc1.14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-09 10:44:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kidboy14 2008-05-21 14:16:45 EDT
Description of problem:
After adding wins to hosts in /etc/nsswitch.conf, attempting to resolve a wins
address fails. Ping fails with a segmentation fault. This only seems to occur if
the machine name exists on the network. Otherwise, the expected "unknown host"
is output. This bug was not present in Fedora 8.


Version-Release number of selected component (if applicable):
samba 3.2.0-1.pre3.9.fc9

How reproducible:


Steps to Reproduce:
1.add "hosts: files dns wins" in nsswitch.conf
2.attempt to resolve a wins hostname
  
Actual results:
Segmentation fault

Expected results:
The name's IP is resolved correctly
Comment 1 kidboy14 2008-05-21 14:18:43 EDT
*edit*:

I also found this ubuntu bug report, which seems to be describing the same
problem. A fix was described, but I do not know whether or not this is the same
issue.
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/39990

Note You need to log in before you can comment on or make changes to this bug.