Bug 447784 - List-Archive URL for private archives broken
List-Archive URL for private archives broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 15:20 EDT by Jan Kratochvil
Modified: 2009-03-31 05:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 05:30:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a patch (775 bytes, patch)
2009-03-31 05:04 EDT, Daniel Novotny
no flags Details | Diff
a patch (755 bytes, patch)
2009-03-31 05:10 EDT, Daniel Novotny
no flags Details | Diff

  None (edit)
Description Jan Kratochvil 2008-05-21 15:20:19 EDT
Description of problem:
If you have a list with a private archive and you follow the mail header present
in the list mails
List-Archive: <http://host0.dyn.jankratochvil.net/mailman/private/vmezihori1>
the URL does not work.

Version-Release number of selected component (if applicable):
mailman-2.1.9-10.fc9.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Create a mailing list.
2. Set its archive to private (`archive_private').
3. Try to browser the List-Archive URL.
4. Click the `[ Thread ]' button.

Actual results:
On URL:
http://host0.dyn.jankratochvil.net/mailman/private/2008-May/thread.html
Message: No such list 2008-may

Expected results:
On URL:
http://host0.dyn.jankratochvil.net/mailman/private/vmezihori1/2008-May/thread.html
The right content.

Additional info:
The problem is on the public archive it is a regular directory where httpd
automatically gives a redirect with a trailing slash.
The private lists are handled by CGI /usr/lib/mailman/cgi-bin/private which does
not give such redirect.
The link from the listinfo page works fine as it has the trailing slash.
Solution:
(1) The List-Archive mail header should also have the trailing slash.
OR
(2) /usr/lib/mailman/cgi-bin/private should return the redirect.
Comment 1 Tomas Smetana 2008-05-22 03:24:41 EDT
Even 2.1.10 has the same bug.  Will look into that.
Comment 2 Daniel Novotny 2009-03-31 05:04:21 EDT
Created attachment 337280 [details]
a patch

the removal of the trailing slash seems to serve no purpose, after consultation with upstream I'll discard it
Comment 3 Daniel Novotny 2009-03-31 05:10:44 EDT
Created attachment 337282 [details]
a patch

a new patch: be better and cleaner: we don't care about the slash at all...
Comment 4 Daniel Novotny 2009-03-31 05:30:11 EDT
fixed in mailman-2.1.12-3.fc11

Note You need to log in before you can comment on or make changes to this bug.