Bug 447821 - Add support for persistent SSL backend connections in mod_proxy
Add support for persistent SSL backend connections in mod_proxy
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd (Show other bugs)
5.1
All Linux
low Severity high
: rc
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 18:30 EDT by Ray Van Dolson
Modified: 2009-05-20 06:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 06:57:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache Bugzilla 43238 None None None Never

  None (edit)
Description Ray Van Dolson 2008-05-21 18:30:48 EDT
Description of problem:


Version-Release number of selected component (if applicable):
httpd-2.2.3-11.el5_1.3

How reproducible:
Always


Steps to Reproduce:
1. Set up Apache + mod_proxy in front of OWA2K7
2. Configure for end to end communication to be via SSL (client -> proxy and
proxy -> IIS).
3. Attempt to access externally from clients that require persistent connections
(Palm Treos)
  
Actual results:
Connection hangs.

Expected results:
Connection succeeds.

Additional info:
After initial OPTIONS request, connection is broken due to Apache inserting a
Connection: Close header.  When no proxy is used, the connection should be kept
open.

This revision:

  http://svn.apache.org/viewvc?view=rev&revision=657440

In the Apache 2.2.x branch appears to fix the issue (in the process of testing).
 I would *love* to see this backported to RHEL 5.x's Apache 2.2.3 tree.

I am testing a home-rolled patch and can file an RFE and also can attach
tcpdumps with and without Apache in the mix.
Comment 1 Joe Orton 2009-05-15 10:20:52 EDT
Are you still seeing problems with the httpd package as of RHEL 5.3?
Comment 2 Ray Van Dolson 2009-05-15 13:23:46 EDT
(In reply to comment #1)
> Are you still seeing problems with the httpd package as of RHEL 5.3?  

I ended up switching to an EL5 build of Fedora's Apache.  I no longer could provide you adequate information to further troubleshoot the issue above, so I'd say go ahead and close this out.
Comment 3 Joe Orton 2009-05-20 06:57:00 EDT
Thanks for the feedback.

Note You need to log in before you can comment on or make changes to this bug.