Bug 447839 - snmptrapd command line does not accept hostname in transport-address
snmptrapd command line does not accept hostname in transport-address
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp (Show other bugs)
4.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Safranek
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 22:56 EDT by Denise Eckstein
Modified: 2009-06-20 00:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* a patch previously applied to the net-snmp packages failed to allow the snmpd and snmptrapd daemons to process hostnames in transport address specifiers. Attempts to use a hostname as the listening address for snmptrap would therefore fail. The previous patch has been replaced by a new version which allows for hostnames in transport address specifiers.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:19:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix (3.44 KB, patch)
2008-06-02 07:05 EDT, Jan Safranek
no flags Details | Diff

  None (edit)
Description Denise Eckstein 2008-05-21 22:56:52 EDT
Description of problem:

The following command fails with net-snmp-5.1.2-11.EL4.11 but runs 
successfully with net-snmp-5.1.2-11.

/usr/sbin/snmptrapd -f -Lf trapLogFile -p procIdFile -F "\nTrap Info: %
P\nVariable: %v\n" UDP6:2006,UDP:gemsbok.cup.hp.com:2006

[root@gemsbok testclient]# cat trapLogFile
2008-05-21 19:45:29 NET-SNMP version 5.1.2 Started.
Invalid port number specified (0), using default (161)

snmptrapd 15821    root    8u  IPv6  26027       UDP *:2006 
snmptrapd 15821    root    9u  IPv4  26028       UDP *:snmptrap 

If I replace gemsbok.cup.hp.com with 127.0.0.1 or remove it entirely, the 
command runs successfully.

[root@gemsbok testclient]# /usr/sbin/snmptrapd -f -Lf trapLogFile -p 
procIdFile -F "\nTrap Info: %P\nVariable: %v\n" UDP6:2006,UDP:127.0.0.1:2006

snmptrapd 15828    root    8u  IPv6  26113       UDP *:2006 
snmptrapd 15828    root    9u  IPv4  26114       UDP gemsbok.cup.hp.com:2006 


Version-Release number of selected component (if applicable):
net-snmp-5.1.2-11.EL4.11


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jan Safranek 2008-05-30 09:07:44 EDT
It's regression caused by wrong bugfix for bug #205154. I'll look at it.
Comment 2 RHEL Product and Program Management 2008-05-30 09:21:44 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 3 Jan Safranek 2008-06-02 07:05:44 EDT
Created attachment 307346 [details]
fix

Attaching patch, which replaces original net-snmp-5.1.2-port.patch.
Comment 5 RHEL Product and Program Management 2008-09-18 08:16:24 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 9 Ruediger Landmann 2009-01-22 01:20:42 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
* a patch previously applied to the net-snmp packages failed to allow the snmpd and snmptrapd daemons to process hostnames in transport address specifiers. Attempts to use a hostname as the listening address for snmptrap would therefore fail. The previous patch has been replaced by a new version which allows for hostnames in transport address specifiers.
Comment 12 errata-xmlrpc 2009-05-18 16:19:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0984.html

Note You need to log in before you can comment on or make changes to this bug.