Bug 447840 - Konquerorsu crash in KDE 4
Konquerorsu crash in KDE 4
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 22:57 EDT by Claudio Guimarães
Modified: 2015-07-13 13:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 09:29:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Claudio Guimarães 2008-05-21 22:57:39 EDT
Description of problem:
Konqueror crashes every time I try to run it as su from any regular user logged
in. If I start from konsole authenticated as root it just freezes and goes
nowhere. It works normaly for the user logged in, regular or root.


Version-Release number of selected component (if applicable):
4.0.4

How reproducible:
everytime

Steps to Reproduce:
1.Start from icon or
2.Start from terminal
3.
  
Actual results:
crash and generates the signal 11 (SIGSEGV)

Expected results:
run as root

Additional info:
It looks to be a reincidence from a bug in KDE 3:
http://bugs.kde.org/show_bug.cgi?id=51381
Comment 1 Kevin Kofler 2008-05-22 00:31:37 EDT
It can't be the same as that KDE 3 bug, that was an issue in mcop which is part 
of aRts. There's no aRts anymore in KDE 4.
Comment 2 Claudio Guimarães 2008-05-22 08:17:08 EDT
I found out that it happens with any KDE application. Dolphin doesn't run,
kwrite runs as normal user despite of root authentication. Tried to install
kdeadmin, issue remains.
Comment 3 Rex Dieter 2008-05-22 08:40:20 EDT
How exactly are you experiencing this?

I can't reproduce.  These all work for me:
1. sudo <kde_app>  
2. su - -c <hde_app>
Comment 4 Kevin Kofler 2008-05-22 08:48:54 EDT
IMHO this is not a bug. You shouldn't run graphical apps through su or sudo, 
this can always cause problems with things like X11 display permissions etc. 
That's what kdesu is for. (It takes care of these things for you.)
Comment 5 Claudio Guimarães 2008-05-22 10:19:16 EDT
KDE has an icon [File management - super user mode]. If clicked it asks for root
password and runs Konqueror. In KDE 3 it works fine. The other way is right
click Desktop: [command run] [run as other user] [type in "root"] [type in "root
password]. I used this frequently in KDE 3 for system configuration with kedit,
kate, konqueror or whatever. I think I was not very clear before. I am not using
su <app>. If I use the konsole I log in as root and only after that I try to run
the app. Anyway the graphical non kde apps run normaly (system-config-xxx for
example).
Comment 6 Rex Dieter 2008-05-22 10:38:07 EDT
[File management - super user mode] : works here
right click Desktop: [command run] [run as other user] ... : works here

shrug, still can't reproduce. ??
Comment 7 Lukáš Tinkl 2008-05-22 10:39:37 EDT
OK, then it looks like the kdesu bug that has been fixed upstream some time 
ago, I'll take care of this; I was waiting for reporter's comment first
Comment 8 Fedora Update System 2008-05-30 22:17:13 EDT
kdelibs-4.0.4-10.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdelibs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4792
Comment 9 Claudio Guimarães 2008-05-31 18:15:43 EDT
Updated, rebooted. Problems persist. The only change is that konqueror runs now
with right click Desktop: [command run] [run as other user] [type in "root"]
[type in "root password], but it runs as the user logged in. No access to system
files is allowed. I have noticed that the problem occurs not only with root but
with any other user. That means: KDE4 let me run KDE apps only for the user
logged in.
PS: I am experiencing a few minor issues with plasma. Shall I report this here
or with KDE bugs? Thank's!
Comment 10 Lukáš Tinkl 2008-06-12 09:29:11 EDT
I can't reproduce either :/ Please file the plasma bugs upstream, at
http://bugs.kde.org

Note You need to log in before you can comment on or make changes to this bug.