Bug 447844 - Review Request: krazy2 - KDE code checking tool
Review Request: krazy2 - KDE code checking tool
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 23:29 EDT by Ben Boeckel
Modified: 2016-08-14 12:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 08:39:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mtasaka: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Ben Boeckel 2008-05-21 23:29:05 EDT
Spec URL: http://hypersonicsoft.org/projects/downloads/PokéGen/misc/krazy2.spec
SRPM URL: http://hypersonicsoft.org/projects/downloads/PokéGen/misc/krazy2-1.11-1.fc9.src.rpm
Description: Krazy scans KDE source code looking for issues that should be fixed
for reasons of policy, good coding practice, optimization, or any other
good reason.
Comment 1 Ben Boeckel 2008-05-22 00:09:03 EDT
Forgot to mention that this is my first package and that I need sponsored.
Comment 2 Ben Boeckel 2008-05-22 01:39:51 EDT
After thinking about it a bit, should the plugins in the package be a separate
RPM (krazy2-plugins perhaps)?
Comment 3 Ben Boeckel 2008-06-16 20:14:26 EDT
The spec and SRPM have been relocated:
http://www.hypersonicosft.org/temp/krazy2-1.11-1.fc9.src.rpm
http://www.hypersonicsoft.org/temp/krazy2.spec
Comment 4 Mamoru TASAKA 2008-07-31 10:05:20 EDT
Rebuild failed:
http://koji.fedoraproject.org/koji/taskinfo?taskID=750060
Comment 5 Ben Boeckel 2008-09-17 00:45:52 EDT
I no longer need sponsored.
See: https://bugzilla.redhat.com/show_bug.cgi?id=450371
Comment 6 Mamoru TASAKA 2008-09-17 01:36:47 EDT
(Re-adding NEEDSPONSOR: see my comment on bug 450371)
Comment 7 Kevin Kofler 2008-09-17 01:46:45 EDT
Of course this fails, the "make PREFIX=/usr install" for the plugins doesn't use RPM_BUILD_ROOT anywhere, so they aren't installed to the right place.
Comment 8 Ben Boeckel 2008-09-17 20:34:52 EDT
Got them more up-to-date here:
http://benboeckel.net/krazy2/krazy2.spec
http://benboeckel.net/krazy2/krazy2-2.6-1.fc9.src.rpm

Here are some of the questions that I have that need attention:
1) There is one file that needs compiling (src/passbyvalue/passbyvalue.cpp) while everything else is noarch (perl scripts)

2) rpmlint errors saying that there are no binaries and it should be noarch, but that plugin is not noarch as it needs compiled. rpmlint doesn't find it and errors saying that it should then be in /usr/share.

Any ideas as to how I should handle that? Maybe an arch-dependent subpackage from a noarch base package?
Comment 9 Ben Boeckel 2008-09-17 20:50:54 EDT
False alarm, thought I had fixed a bug before and didn't think it came from there:
http://benboeckel.net/krazy2/krazy2.spec
http://benboeckel.net/krazy2/krazy2-2.6-2.fc9.src.rpm

Fixed it. Had to patch to get it to accept LIBSUFFIX in passbyvalue. Now it actually installs to the right place.
Comment 10 Mamoru TASAKA 2008-09-18 02:08:04 EDT
Still rebuild fails: needs investigating...
http://koji.fedoraproject.org/koji/taskinfo?taskID=831427

By the way, are you trying rpmbuild as root? If so, please try
rpmbuild as a normal user. After you setup rpmdev tree by
rpmdev-setuptree (in rpmdevtools rpm) as a normal user, you should be able to 
try rpmbuild as the user.
Comment 11 Ben Boeckel 2008-09-18 11:13:49 EDT
Yes, I run (ran) it as root. Fixed it up. Thanks.

http://benboeckel.net/krazy2/krazy2.spec
http://benboeckel.net/krazy2/krazy2-2.6-3.fc9.src.rpm
Comment 12 Mamoru TASAKA 2008-09-18 13:19:58 EDT
For 2.6-3:
* Source0
  - Source tarball must be written by full URL
    https://fedoraproject.org/wiki/Packaging/SourceURL

* BuildRequires
-------------------------------------------
   327  + pushd doc
   328  + make DESTDIR=/builddir/build/BUILDROOT/krazy2-2.6-3.fc10.i386/usr/share/man install
   329  perldoc krazyrc.pod > krazyrc.5
!!!330  sh: nroff: command not found
   331  list=krazyrc.5; for man in $list; do \
   332                  echo "Installing man page $man"; \
   333                  mv -f $man /builddir/build/BUILDROOT/krazy2-2.6-3.fc10.i386/usr/share/man/man5/$man; \
   334          done
   335  Installing man page krazyrc.5
   336  + popd
-------------------------------------------
   - Perhaps "groff" is needed for BuildRequires.

* man files
  - Files under %_mandir are automatically regarded as %doc.

* Directory ownership issue
  - The directory %{perl_vendorlib}/Krazy/ is not owned by any packages

* Documents
  - Please add the following files to %doc.
-------------------------------------------
COPYING
README
-------------------------------------------
Comment 13 Ben Boeckel 2008-09-18 13:53:34 EDT
Fixed. Also added the svn revision number as upstream doesn't bump the version when it gets updated.

http://benboeckel.net/krazy2/krazy2.spec
http://benboeckel.net/krazy2/krazy2-2.6-4.20080918svn862357.fc9.src.rpm
Comment 14 Mamoru TASAKA 2008-09-19 01:50:55 EDT
Okay.

* One issue
  - "Requires: desktop-file-utils" is not needed.

----------------------------------------------------------
     This package (krazy2) is APPROVED by mtasaka
----------------------------------------------------------
Comment 15 Ben Boeckel 2008-09-19 08:26:46 EDT
(In reply to comment #14)
> * One issue
>   - "Requires: desktop-file-utils" is not needed.
Actually, it is. Krazy uses desktop-file-validate (it has 0.14 upstream, 0.15 is in Fedora, so I went with that). Should I comment that in the spec file?
Comment 16 Mamoru TASAKA 2008-09-19 09:06:25 EDT
(In reply to comment #15)
> (In reply to comment #14)
> > * One issue
> >   - "Requires: desktop-file-utils" is not needed.
> Actually, it is. Krazy uses desktop-file-validate (it has 0.14 upstream, 0.15
> is in Fedora, so I went with that). Should I comment that in the spec file?

Ah, okay. Then I recommend to write in a spec file.
Comment 17 Mamoru TASAKA 2008-09-19 09:47:26 EDT
(Now I am sponsoring the submitter)
Comment 18 Ben Boeckel 2008-09-19 10:21:27 EDT
New Package CVS Request
=======================
Package Name: krazy2
Short Description: KDE code checking tool
Owners: mathstuf
Branches: F-8 F-9
InitialCC:
Comment 19 Kevin Fenzi 2008-09-20 20:32:19 EDT
cvs done.
Comment 20 Mamoru TASAKA 2008-09-23 08:17:09 EDT
For F-8 and F-9, please submit requests on bodhi:
https://admin.fedoraproject.org/updates/
to push the built packages to repositories, then you can close
this bug.
Comment 21 Ben Boeckel 2008-09-23 08:39:44 EDT
Just did it this morning (was away for the weekend). Closing.

Note You need to log in before you can comment on or make changes to this bug.