Bug 447897 - Description/template for release notes field in new bugzilla
Description/template for release notes field in new bugzilla
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: Noura El hawary
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 08:11 EDT by Noura El hawary
Modified: 2013-06-24 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-29 22:13:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
description for release notes field (3.09 KB, patch)
2008-05-22 08:41 EDT, Noura El hawary
dkl: review-
Details | Diff

  None (edit)
Description Noura El hawary 2008-05-22 08:11:38 EDT
Release Note:

Data in this field will be used to extract a meaningful summary of the
resolution status of the bug
for use by release notes and change logs. The recommended template is:

Cause:
Consequence:
Fix:
Result:

The definition of the recommended template is below:

Cause:
=======
What actions or circumstances cause this bug to present.

Consequence:
============
What happens when the bug presents.

Fix:
====
What was done to fix the bug.

Result:
=======
What now happens when the actions or circumstances above occur. (NB: this is not
the same as 'the
bug doesn't present anymore')
Comment 1 Noura El hawary 2008-05-22 08:12:01 EDT
Hi Noura,

Great work on the Release Note field for Bugzilla.

Any chance the word Release Note can be a link to another page (similar to
keywords) that provides the expository below?

Cheers,
Mike

> [mhideo@redhat.com - Tue May 20 21:15:11 2008]:
>
> Release Note:
>
> Data in this field will be used to extract a meaningful summary of the
> resolution status of the bug
> for use by release notes and change logs. The recommended template is:
>
> Cause:
> Consequence:
> Fix:
> Result:
>
> The definition of the recommended template is below:
>
> Cause:
> =======
> What actions or circumstances cause this bug to present.
>
> Consequence:
> ============
> What happens when the bug presents.
>
> Fix:
> ====
> What was done to fix the bug.
>
> Result:
> =======
> What now happens when the actions or circumstances above occur. (NB:
> this is not the same as 'the
> bug doesn't present anymore')
>
> 
Comment 2 Noura El hawary 2008-05-22 08:41:11 EDT
Created attachment 306366 [details]
description for release notes field

Attached is a patch that adds [Help] link next to the Release Notes input box
,, when the Help is clicked it takes you to a page with a description/template
of what should be entered in this field.

Please review and let me know what you think.

Thanks,
Noura
Comment 3 David Lawrence 2008-05-23 12:51:28 EDT
Comment on attachment 306366 [details]
description for release notes field

>Index: template/en/default/bug/field.html.tmpl
>@@ -105,6 +105,7 @@
>        [% INCLUDE global/textarea.html.tmpl
>            id = field.name name = field.name minrows = 4 maxrows >= 8
>            cols = 60 defaultcontent = value %]
>+       [% Hook.process('help') %]
>   [% END %]

Place the [% Hook.process('help') %] outside of the SWITCH block so it can be
used with other fields other than FIELD_TYPE_TEXTAREA.
I can see where it would be useful for other custom fields to have a help page
if needed.

Also you may need to add a   or other spacing tag that will push the
[Help] link alittle further away from the side of the input area. Currently it
is right against the side due to the way textarea fields interact with data
around it. A single   before the [Help] should be sufficient.

>Index: template/en/default/pages/fields.html.tmpl
>===================================================================
> 
>+[% Hook.process('release_notes') %]
>+

Looks good Noura. Only thing I would change is here I would call it 'extra'
instead of being specific. All Hook names should be as generic as possble so
they can be reused by other extensions. So:

[% Hook.process('extra') %]

Then then template would be named:

extensions/redhat_fields/template/en/pages/fields-extra.html.tmpl

Then we can just add more data to that template file as we need to add more
help in the future.

Fix these and then dkl=review+ and check in.

Dave
Comment 4 Noura El hawary 2008-05-29 22:13:10 EDT
all done and pushed to cvs and live in the beta version

Note You need to log in before you can comment on or make changes to this bug.