Bug 447905 - Error in lvchange(8)
Error in lvchange(8)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Dave Wysochanski
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 08:34 EDT by Jordi Mallach
Modified: 2010-01-11 22:53 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:47:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordi Mallach 2008-05-22 08:34:32 EDT
lvchange(8) describes the following available arguments for -a:
       -a, --available y/n/ey/en/ly/ln

However, the description has an error, mentioning "-ae" which doesn't exist:
              If  clustered  locking is enabled, -ae will activate exclusively
              on one node and -aly will activate only on the local  node.   To
              deactivate  only  on  the  local node use -aln.  Logical volumes
              with single-host  snapshots  are  always  activated  exclusively
              because they can only be used on one node at once.

It's probably -aey or -aen, but not -ae.
Comment 1 Dave Wysochanski 2008-06-02 11:50:37 EDT
Agreed the man pg should be consistent.  Note though that 'ae' is equivalent to
'aey' (and 'aye' for that matter) in the code:

int yes_no_excl_arg(struct cmd_context *cmd __attribute((unused)),
		    struct arg *a)
{
	a->sign = SIGN_NONE;
	a->percent = PERCENT_NONE;

	if (!strcmp(a->value, "e") || !strcmp(a->value, "ey") ||
	    !strcmp(a->value, "ye")) {
		a->i_value = CHANGE_AE;
		a->ui_value = CHANGE_AE;
	}

	else if (!strcmp(a->value, "y")) {
		a->i_value = CHANGE_AY;
		a->ui_value = CHANGE_AY;
	}

	else if (!strcmp(a->value, "n") || !strcmp(a->value, "en") ||
		 !strcmp(a->value, "ne")) {
		a->i_value = CHANGE_AN;
		a->ui_value = CHANGE_AN;
	}

	else if (!strcmp(a->value, "ln") || !strcmp(a->value, "nl")) {
		a->i_value = CHANGE_ALN;
		a->ui_value = CHANGE_ALN;
	}

	else if (!strcmp(a->value, "ly") || !strcmp(a->value, "yl")) {
		a->i_value = CHANGE_ALY;
		a->ui_value = CHANGE_ALY;
	}
Comment 2 Dave Wysochanski 2008-06-02 11:56:08 EDT
Now upstream will be in next releases (2.02.38+).
Comment 3 RHEL Product and Program Management 2008-07-01 07:42:49 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Milan Broz 2008-07-03 05:36:22 EDT
Commited to CVS in version lvm2-2.02.39-1.el5.
Comment 7 errata-xmlrpc 2009-01-20 16:47:01 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0179.html

Note You need to log in before you can comment on or make changes to this bug.