Bug 447918 - Thunderbird Lightning cannot change date views
Thunderbird Lightning cannot change date views
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 09:38 EDT by John Dennis
Modified: 2008-05-27 17:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 17:11:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Dennis 2008-05-22 09:38:54 EDT
With Thunderbird 2.0.0.14 and Lightning 0.8 click on the calendar view, by
default you'll get a "Day View", if you try to change to any other date view
(Multidday, Week, Month) nothing happens. This is true irregardeless of whether
you use the view buttons on the toolbar or the view menu items.
Comment 1 John Dennis 2008-05-22 09:47:43 EDT
BTW, Lightning 0.8 with Thunderbird 2.0.0.12 in F-8 does not exhibit this
behavior. Since both Lightning addons are 0.8 the only difference is the
Thunderbird version and OS version.
Comment 2 Lubomir Rintel 2008-05-25 17:24:18 EDT
John: Have you tried with xpi installer from Lightning upstream?
Comment 3 John Dennis 2008-05-27 11:18:11 EDT
Yes I used the xpi installer downloading lighting from the mozilla web site. I
did not install from a Fedora repo.
Comment 4 Lubomir Rintel 2008-05-27 11:25:13 EDT
Bouncing back to Thunderbird package then.
Comment 5 Matěj Cepl 2008-05-27 16:37:35 EDT
Cannot reproduce with thunderbird and lightining from Fedora repos. I don't
think we support upstream lighting plugin when we have native build available.

thunderbird-2.0.0.14-1.fc9.i386
thunderbird-lightning-0.8-3.fc9.i386

Reporter, do you have any idea, how to reproduce this bug just using Fedora
packages?
Comment 6 John Dennis 2008-05-27 17:00:05 EDT
Well silly me, I used the tools provided by Thunderbird to find and install the
Lightning extension :-) Had I instead used 'yum install thunderbird-lightning' I
would have gotten something which did work, how silly to not know the extensions
must be built by us and that one should never ever use the ones pointed to by
the application.

Maybe the bug report should be changed to "Thunderbird suggests installing
extensions we know won't work" In other words never follow the link in the
"Add-On Dialog box" which says "Get Extensions". Or maybe that link should point
to a yum repo instead.
Comment 7 Matěj Cepl 2008-05-27 17:11:16 EDT
John, the point is that Lighting is fairly huge extension (which is the reason
why it is packaged at Fedora in the first place) with a lot of compiled C-code.
Unfortunately, upstream compiles with some really old and obsolete tools and
libraries, so although on F9 upstream extension should work (especially with
installing appropriate name packages), I wouldn't expect (especially from big
ones) that much miralces.

Note You need to log in before you can comment on or make changes to this bug.