Bug 447923 - MCAST_JOIN_GROUP sockopt fails for compat binaries.
MCAST_JOIN_GROUP sockopt fails for compat binaries.
Status: CLOSED DUPLICATE of bug 444582
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Thomas Graf
Martin Jenner
:
Depends On: 447922
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 09:53 EDT by Ric Wheeler
Modified: 2014-06-18 04:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-18 17:17:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2008-05-22 09:53:02 EDT
+++ This bug was initially created as a clone of Bug #447922 +++

Someone told me IP{V6,}_ADD_MEMBERSHIP sockopts were deprecated and we should
use MCAST_JOIN_GROUP instead. That fails for 32-bit userspace on 64-bit kernels,
though. Fixed by upstream commit dae50295.

Test case at http://david.woodhou.se/MulticastTest.c should print '5 bytes
received' but will just hang.
Comment 2 Thomas Graf 2008-06-18 17:17:20 EDT
Patch is already included in the patch that was posted for
https://bugzilla.redhat.com/show_bug.cgi?id=444582

*** This bug has been marked as a duplicate of 444582 ***

Note You need to log in before you can comment on or make changes to this bug.