Bug 447929 - gstreamer errors with user but not with root.
Summary: gstreamer errors with user but not with root.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-22 14:11 UTC by Jonathan Barnett
Modified: 2014-10-29 01:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-07-14 14:58:53 UTC


Attachments (Terms of Use)

Description Jonathan Barnett 2008-05-22 14:11:47 UTC
Description of problem: On installation of Fedora 9 onto an Acer 1640
Travelmate, Rhythmbox will not play a music CD (nor any file) under the normal
username. All ownership of the disk drives and related hardware has been
assigned to the normal user, and the normal user has been added to the same
group as the disk drive. Root is needed to play music CDs and files. Both aplay
and paplay work, however the gstreamer-properties test fails. (All system
sounds, Youtube, and any additional sounds play as desired) I am using USB speakers.


Version-Release number of selected component (if applicable):

Latest as of the 22nd of May 2008

How reproducible:
See steps below.

Steps to Reproduce:
1. Install on a ~4 year old laptop. An Acer model
2. Add the normal user to "disk" and its own group.
3. chown the disk drive to the user, along with all related hardware
4. Try to play something. Root will work. Normal user will not.
  
Actual results:
Rhythmbox gives back a "Playback Error", and in the left-most column, a "No
Entry" sign appears. This happens with all files. Root solves this problem.


Expected results:
CDs, WAVs, OGGs and such, playable in Rhythmbox.

Additional info:
Using USB speakers, however this should not be an issue, seeing as everything
else plays fine.

Comment 1 Michal Schmidt 2008-05-22 14:26:59 UTC
I tried to help Jonathan on #fedora with this problem. Someone else had already
advised him to fiddle with the permissions of sound and CD devices, which was
unfortunate IMHO, but anyway...  ALSA and PulseAudio seem to work fine, because
these commands both produced sound for Jonathan:
 aplay /usr/share/sounds/startup3.wav
 paplay -v /usr/share/sounds/startup3.wav

He tried the Test button in gstreamer-properties -> Audio -> Default Output.
Both ALSA and PulseAudio plugins failed with "Can not open the output device for
playback".

Jonathan, please correct me if I'm mistaken in anything in this comment.

Comment 2 Bastien Nocera 2008-09-01 15:39:17 UTC
What do you see on the command-line when using either gstreamer-properties or Rhythmbox and reproducing this problem?

Comment 3 Bug Zapper 2009-06-10 01:05:49 UTC
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Bug Zapper 2009-07-14 14:58:53 UTC
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 5 Jonathan Barnett 2014-10-29 01:02:08 UTC
If this bug is closed, why do I keep getting spam emails every fucking couple of days? I haven't used this shit since mid 2008. Stop fucking bothering me.


Note You need to log in before you can comment on or make changes to this bug.