Bug 447961 - polkit-gnome-authorization doesn't show beneficiaries
polkit-gnome-authorization doesn't show beneficiaries
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: PolicyKit-gnome (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 12:47 EDT by Edouard Bourguignon
Modified: 2013-03-05 22:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-23 02:13:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edouard Bourguignon 2008-05-22 12:47:41 EDT
Description of problem:

The polkit-gnome-authorization GUI doesn't show all the users you granted to do
specific actions. They don't appear in the Explicit Authorizations list. And of
course when you try to grant a user which has already been granted you have this
error:

** (polkit-gnome-authorization:3362): WARNING **: Error granting auth:
AuthorizationAlreadyExists: An authorization for uid 501 for the action
org.freedesktop.consolekit.system.stop-multiple-users with constraint '' already
exists

Version-Release number of selected component (if applicable):

PolicyKit-gnome-0.8-4.fc9.x86_64

How reproducible:

Static. Only the current user seems to appear, even root can't see the existing
policies for all the users.

Steps to Reproduce:
1. run polkit-gnome-authorization
2. grant some users on a specific action
  
Actual results:

Explicit Authorizations doesn't list anything but your current user granted
authorisation.

Expected results:

Explicit Authorizations should list users granted on the specific action.

Additional info:

If it's not a bug, how or which user is allowed to manage the policies for all
the users?

Files /var/lib/PolicyKit/user-xxx.auths are perfectly created by the GUI, and
the policies seem to apply.
Comment 1 Matthias Clasen 2008-05-22 17:27:45 EDT
There is a checkbox "Show authorizations for all users" below the list.
You need to check that to see all grants.
You have a point about the warning though.
Comment 2 Edouard Bourguignon 2008-05-23 02:13:34 EDT
ok, so the problem was: I need more coffee :)

Note You need to log in before you can comment on or make changes to this bug.