Bug 447983 - DVD innstall cannot update software from DVD
DVD innstall cannot update software from DVD
Status: CLOSED DUPLICATE of bug 435625
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 14:57 EDT by Bruce Butterfield
Modified: 2008-05-23 02:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-23 02:36:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Butterfield 2008-05-22 14:57:28 EDT
Description of problem:
I successfully installed Fedora 9 on a new computer. I accepted the initial
software selection, and also checked to add development code. The installation
indicated that I could make a more specific selection of the packages during
installation, but that it was not necessary since it could be done later. 

After the installation I attempted to add software packages, using the program
provided through the menu system. The program immediately terminated, since I
did not have a network connection to that unit.


Version-Release number of selected component (if applicable): Fedora 9.0

How reproducible:  100% 

Steps to Reproduce:
1. Remove a network connection
2. Attempt to change the software installation
3.
  
Actual results:  Without a network connection, the user has no obvious way to
change the software installed on the unit, since the program terminates immediately.

Expected results:  I have installed various other Linux distros from CD/DVD, and
older versions of Red Hat / Fedora (before version 4.0), and after the initial
installation the user is allowed to change the package selection using the
packages provided on the CD/DVD.  "Synaptic" is very good at handling this,
since it allows you to insert multiple DVDs, and selectively enable or disable
which ones are usable.


Additional info:  I bugged this back about Fedora Core 4.0, when there was a
change to use YUM and PIRUT.  At that time there was at least instructions
provided on how to manually make a local YUM repository by copying all of the
DVD files to the hard drive. If that documentation still exists, I could not
find it at the Fedora web site. 

Most of my computers are NOT connected to the Internet, and it is not practical
to do a complete reinstall to change the package selection. Since I can buy a
Fedora / SuSE / Ubuntu installation DVD for about $2, and a Debian set for about
$6, it is highly practical to update using only DVDs, and still be able to
update more than once a year. This is also the only reasonable way to update
computers which have a slow internet connection.
Comment 1 Richard Hughes 2008-05-23 02:36:57 EDT

*** This bug has been marked as a duplicate of 435625 ***

Note You need to log in before you can comment on or make changes to this bug.