Bug 447994 - wireshark hangs when clicking on Capture Interfaces "Options"
Summary: wireshark hangs when clicking on Capture Interfaces "Options"
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: wireshark
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Radek Vokál
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-22 19:46 UTC by Charles R. Anderson
Modified: 2009-07-14 16:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-07-14 16:24:46 UTC


Attachments (Terms of Use)
stacktrace (6.23 KB, text/plain)
2008-12-05 05:07 UTC, Andrew Schultz
no flags Details

Description Charles R. Anderson 2008-05-22 19:46:44 UTC
Description of problem:

Clicking on the "Options" button in the Capture Interfaces dialog causes
wireshark to hang completely.

Version-Release number of selected component (if applicable):
1.0.0-2.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1. open wireshark
2. click Capture->Interfaces
3. click "Options" on any interface in the list

Comment 1 Radek Vokál 2008-05-22 19:58:18 UTC
can you please start wireshark from console/terminal and let me know what it
says? also if you can install the debuginfo package and send me a core.dump file.

Comment 2 Charles R. Anderson 2008-05-22 20:27:56 UTC
I am starting it from the terminal, and there is no output.  It doesn't crash,
so it doesn't create a core dump file.  I have to kill it manually to recover,
or click the X close box and wait for the "this window isn't responding" to pop up.


Comment 3 Radek Vokál 2008-09-10 11:07:36 UTC
I still can't reproduce your issue even with wireshark 1.0.3. Can you please retest with the latest version? Also remove ~/.wireshark directory and root/.wireshark

Comment 4 porkroast 2008-09-20 15:07:59 UTC
I experienced this "bug" also.

When wireshark starts, a small message window pops up in the upper left corner of the desktop warning the user about running programs as root, and waits for user input (click the "OK" button).  The main application window quickly covers it, and the main window won't respond until the user clicks OK on the 1st message window.

Thought I'd post this to save someone else a problem.

Comment 5 Andrew Schultz 2008-12-05 05:07:04 UTC
Created attachment 325800 [details]
stacktrace

I'm seeing this on Fedora 10 (wireshark 1.0.3-1.fc10) with ~/.wireshark/ removed.  I'm attaching the stacktrace from gdb.

Comment 6 Charles R. Anderson 2008-12-13 21:52:54 UTC
I no longer see this issue.  I'm currently using 1.0.3-1.fc10.

(In reply to comment #5)
> I'm seeing this on Fedora 10 (wireshark 1.0.3-1.fc10) with ~/.wireshark/
> removed.  I'm attaching the stacktrace from gdb.

Are you sure you dismissed the pop-under dialog box that says "Running as user root and group root.  This could be dangerous."?  It gets me every time, but my original issue was different, only hanging after clicking "Options".

Comment 7 Andrew Schultz 2008-12-14 00:11:16 UTC
> Are you sure you dismissed the pop-under dialog box...

Yes.  I'm not sure how you could see this bug if you don't.  With the dialog up, I can't bring up the dialog with the "Options" button.  The UI is unresponsive but not frozen.

Comment 8 Jon Escombe 2008-12-18 13:00:08 UTC
I also see this issue with wireshark-1.0.5-1.fc10.i386, clicking on any button within the Capture Interfaces window causes wireshark to hang.

Killing the running dumpcap process allows wireshark to continue. Strangely this only happens for certain user accounts on my machine, however I have not been able to determine what is different between working and non-working accounts.

Removing the ~/.wireshark directory makes no difference to this behaviour.

Comment 9 Vidhya 2008-12-31 10:53:35 UTC
I too faced the same problem.
If you want to start capturing packets using an interface,
then you can follow below procedure.

1. Edit -> preferences -> Capture
You can select the interface name and save it.

Packets can then be captured by pressing 'Start a new live capture' icon.

Comment 10 Derek Atkins 2009-01-14 14:19:22 UTC
I just upgraded to FC 10 and running wireshark-1.0.5-1.fc10.i386 I have this problem, too.  I started it from the terminal and get no output.  If I click on "List the available interfaces" and then select "wlan0" wireshark hangs like everyone else is reporting.

However the workaround in Comment #9 worked for me.

Comment 11 Jon Escombe 2009-03-02 12:24:31 UTC
This issue is fixed by the following SIGPIPE patch, as applied to upstream SVN.

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=1740

Could this patch be applied to the current Fedora package until it's available in an upstream release?

Comment 12 Bug Zapper 2009-06-10 01:06:06 UTC
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 Derek Atkins 2009-06-10 14:09:40 UTC
This is definitely still an issue in Fedora 10.  I haven't tried F11.
This isn't my bug so I can't change the version, it is IS still an issue.

Comment 14 Jon Escombe 2009-06-11 12:53:45 UTC
I can confirm it's fixed upstream in the version that's shipped with F11.

Comment 15 Bug Zapper 2009-07-14 16:24:46 UTC
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.