Bug 448003 - somewhat overzealous oops collection
somewhat overzealous oops collection
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kerneloops (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 16:29 EDT by Bill Nottingham
Modified: 2014-03-16 23:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-13 10:48:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-05-22 16:29:55 EDT
Description of problem:

From my logs:

sd 7:0:0:0: [sdb] Device not ready: Sense Key : Not Ready [current] 
sd 7:0:0:0: [sdb] Device not ready: Add. Sense: Medium not present
end_request: I/O error, dev sdb, sector 6496
Buffer I/O error on device sdb1, logical block 808
lost page write due to I/O error on sdb1
Aborting journal on device sdb1.
------------[ cut here ]------------
WARNING: at fs/buffer.c:1183 mark_buffer_dirty+0x2b/0x7c() (Not tainted)
Modules linked in: loop vfat fat nls_utf8 tun ipt_MASQUERADE iptable_nat nf_nat
bridge bnep rfcomm l2cap bluetooth fuse sunrpc nf_conntrack_netbios_ns
nf_conntrack_ipv4 xt_state nf_conntrack ipt_REJECT iptable_filter ip_tables
xt_tcpudp ip6t_REJECT ip6table_filter ip6_tables x_tables ipv6 cpufreq_ondemand
acpi_cpufreq freq_table dm_multipath uinput kvm_intel kvm snd_hda_intel
snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss
snd_mixer_oss snd_pcm thinkpad_acpi i915 snd_timer nsc_ircc irda sr_mod cdrom
hwmon drm snd_page_alloc pata_acpi arc4 ecb crc_ccitt snd_hwdep video battery ac
i2c_i801 i2c_algo_bit bay iwl3945 snd button ata_piix output iTCO_wdt mac80211
ata_generic i2c_core iTCO_vendor_support cfg80211 soundcore e1000e sg
usb_storage sha256_generic cbc aes_x86_64 aes_generic dm_crypt crypto_blkcipher
dm_snapshot dm_zero dm_mirror dm_mod ahci libata sd_mod scsi_mod ext3 jbd
mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded: microcode]
Pid: 25943, comm: kjournald Not tainted 2.6.25-14.fc9.x86_64 #1

Call Trace:
 [<ffffffff81034585>] warn_on_slowpath+0x60/0x91
 [<ffffffff810c62be>] ? sync_buffer+0x0/0x3f
 [<ffffffff810c5b6a>] mark_buffer_dirty+0x2b/0x7c
 [<ffffffff88026a39>] :jbd:journal_update_superblock+0x78/0xc8
 [<ffffffff88026bd3>] :jbd:__journal_abort_soft+0x9b/0xa4
 [<ffffffff88026568>] ? :jbd:__journal_remove_journal_head+0x108/0x10d
 [<ffffffff88026be5>] :jbd:journal_abort+0x9/0xb
 [<ffffffff88024646>] :jbd:journal_commit_transaction+0xb67/0xe95
 [<ffffffff8103dfff>] ? try_to_del_timer_sync+0x58/0x64
 [<ffffffff88027377>] :jbd:kjournald+0xe5/0x223
 [<ffffffff81047b03>] ? autoremove_wake_function+0x0/0x38
 [<ffffffff88027292>] ? :jbd:kjournald+0x0/0x223
 [<ffffffff810477e3>] kthread+0x49/0x76
 [<ffffffff8100ccf8>] child_rip+0xa/0x12
 [<ffffffff8104779a>] ? kthread+0x0/0x76
 [<ffffffff8100ccee>] ? child_rip+0x0/0x12

---[ end trace 1d830417f8b35780 ]---

While this is a oops-like trace, I'm not sure kerneloops.org needs to track that
I ejected the mounted SD card.

Don't know if there's an easy way to distinguish those traces from 'real' ones
though.

Version-Release number of selected component (if applicable):

kerneloops-0.10-11.fc9.x86_64
Comment 1 Arjan van de Ven 2008-09-13 10:36:25 EDT
kerneloops.org really wants to track this; this is a real kernel bug and one that is actually more nasty than one might think on first sight.

Your action is benign (well some kernel developers quite disagree and will consider what you did very harmful, since you unplugged a mounted and active fs), but the kernel should not trip over it, but it did.
Comment 2 Chuck Ebbert 2008-09-13 10:48:19 EDT
You got a lost page write and a journal abort from ejecting a card with a mounted filesystem. We do want to see journal abort messages and can't really filter them out based on cause.

Note You need to log in before you can comment on or make changes to this bug.