Bug 448020 - X crashes if DRI2 is enabled
X crashes if DRI2 is enabled
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 19:18 EDT by Ilya Eremin
Modified: 2009-09-06 04:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 04:40:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log (19.07 KB, text/plain)
2008-05-22 19:18 EDT, Ilya Eremin
no flags Details
xorg.conf (702 bytes, text/plain)
2008-05-22 19:19 EDT, Ilya Eremin
no flags Details

  None (edit)
Description Ilya Eremin 2008-05-22 19:18:38 EDT
I tried enabling DRI 2 in xorg.conf, but seems that it crashes KDE on log in
(with KDE effects enabled).
The error seems to be:
(EE) [drm] Could not set DRM device bus ID.
(EE) intel(0): [dri] DRIScreenInit failed. Disabling DRI.

After this it goes back to KDM

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML
Express Integrated Graphics Controller (rev 03)
Comment 1 Ilya Eremin 2008-05-22 19:18:38 EDT
Created attachment 306429 [details]
X log
Comment 2 Ilya Eremin 2008-05-22 19:19:30 EDT
Created attachment 306430 [details]
xorg.conf
Comment 3 Ilya Eremin 2008-05-23 04:28:06 EDT
OK, I was a bit wrong. The crash is due to the other 3 options (still trying to
find out which one exactly). But the bug remains, now I have
direct rendering: No (If you want to find out why, try setting
LIBGL_DEBUG=verbose) and same errors in Xorg.0.log
Comment 4 Bug Zapper 2008-11-25 21:19:35 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Vedran Miletić 2009-09-06 04:40:00 EDT
I remember having the same issue, but this was fixed long time ago. Reporter, if you are still seeing this, please reopen.

Note You need to log in before you can comment on or make changes to this bug.