Bug 448024 - White X with openchrome driver
White X with openchrome driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 19:58 EDT by chris desjardins
Modified: 2018-04-11 03:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-28 18:47:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (disregard .new) (3.18 KB, text/plain)
2008-05-22 19:58 EDT, chris desjardins
no flags Details
xorg log (46.15 KB, text/plain)
2008-05-22 19:59 EDT, chris desjardins
no flags Details
new xorg log (12.66 KB, text/plain)
2008-05-24 19:01 EDT, chris desjardins
no flags Details
Latest xorg log (106.17 KB, text/plain)
2008-05-26 12:39 EDT, chris desjardins
no flags Details
screenshot of X (1.98 MB, image/jpeg)
2008-05-27 20:27 EDT, chris desjardins
no flags Details

  None (edit)
Description chris desjardins 2008-05-22 19:58:50 EDT
Description of problem:
When I boot the KDE live cd (Fedora 9) then the screen turns reddish then white
when rhgb loads or when loading X if I load w/o that parameter.  After this
happened, I decided to try to use the vesa driver (xdriver=vesa) and that
doesn't work.  It would load up to KDE but my screen would be blank the whole
time.  I could tell it loaded up into KDE because I could hear audio.  I tried
added Option ForcePanel to xorg.conf when I was using openchrome but to no
avail, all that did for me was turn red to purple then to white.  Note that this
laptop works fine with Fedora 8 with openchrome with the Option "ForcePanel"
added.  This is a regression.  Feel free to move severity to medium but
obviously this is high and a show stopper for me :(.  

Version-Release number of selected component (if applicable):
Default version in Fedora 9

How reproducible:
Always

Steps to Reproduce:
1.  Load CD wait for rhgb to load
2.
3.
  
Actual results:
Screen turns reddish/brown then to white

Expected results:
To see rhgb.  

Additional info:
Comment 1 chris desjardins 2008-05-22 19:58:50 EDT
Created attachment 306432 [details]
xorg.conf (disregard .new)
Comment 2 chris desjardins 2008-05-22 19:59:15 EDT
Created attachment 306433 [details]
xorg log
Comment 3 Xavier Bachelot 2008-05-24 13:24:57 EDT
Can you please add to the Device section of your xorg conf :

Option     "ActiveDevice" "LCD"
Option     "ForcePanel"

and send the corresponding xorg log ?
Comment 4 chris desjardins 2008-05-24 19:01:24 EDT
Created attachment 306591 [details]
new xorg log
Comment 5 chris desjardins 2008-05-24 19:02:28 EDT
X still doesn't start with those options.  It goes blank.  However, when I kill X
it says X: symbol lookup error: /usr/lib/xorg/modules/drivers/openchrome_drv.so:
undefined symbol: xf86strstr.

Not sure if that's useful or not.  
Comment 6 Xavier Bachelot 2008-05-25 17:40:49 EDT
The undefined symbol is indeed a bug. I got a fix for it, but the fedora build
system is currently under maintenance...
Comment 7 chris desjardins 2008-05-26 12:39:04 EDT
I am attaching a more recent xorg log.  This is with your unofficial rpm that I
obtained on irc.  Also if I let X go out to the end I can hear the KDE log in
music and it ends up with the screen being 1/2 black and the other 1/2 consisting
of multicolored vertical lines.  
Comment 8 chris desjardins 2008-05-26 12:39:49 EDT
Created attachment 306689 [details]
Latest xorg log
Comment 9 Xavier Bachelot 2008-05-26 19:01:05 EDT
xorg-x11-drv-openchrome-0.2.902-5.fc9 might work better for you. Available from
Koji before it hits updates-testing. 
http://koji.fedoraproject.org/koji/taskinfo?taskID=629814
Comment 10 chris desjardins 2008-05-26 20:34:51 EDT
Well it works better for sure.  The first time I tried the driver it loaded X
(i.e. the screen came up with the options mentioned above) however it ultimately
froze before fully loading KDE and per usually I was unable to recover my X log. 
The next time I tried it I had a scrambled X.  So it looks like it's getting
closer.  
Comment 11 Xavier Bachelot 2008-05-27 16:21:32 EDT
can you please try adding Option "NoAccel" ?
Comment 12 Xavier Bachelot 2008-05-27 16:38:33 EDT
or better, first try Option "AccelMethod" "EXA" and if it still doesn't work,
try Option "NoAccel".
Comment 13 chris desjardins 2008-05-27 19:48:07 EDT
Unfortunately that still didn't work.  I am attaching a screen shot of what it
looks like with the parameters added that you've mentioned.
Comment 14 chris desjardins 2008-05-27 20:27:28 EDT
Created attachment 306860 [details]
screenshot of X
Comment 15 Xavier Bachelot 2008-05-30 05:03:50 EDT
Could you please post the xorg log from xorg-x11-drv-openchrome-0.2.902-5.fc9
with  Option "NoAccel" ?
Comment 16 chris desjardins 2008-05-30 09:07:05 EDT
Unfortunately I can't.  It freezes my computer and I'm not able to ssh into it
to recover it.  
Comment 17 chris desjardins 2008-06-20 13:19:33 EDT
Any more ideas?  I am now running Rawhide in hopes it will fix my problem. 
Seems the -7 openchrome driver gives a backtrace.
Comment 18 Xavier Bachelot 2008-06-30 19:24:46 EDT
Chris, there's a new version in rawhide, xorg-x11-drv-openchrome-0.2.902-8.fc10.
Does it work ?
Comment 19 Matěj Cepl 2008-07-28 18:42:03 EDT
Reporter, could you please reply to the previous question? If you won't reply in
one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 20 Warren Togami 2008-07-28 20:43:16 EDT
I saw a white X a few days ago.  It turned out to be the user account was set to
use compiz, but I logged in from a machine using qemu-kvm with cirrus emulated
hardware.  The display was entirely white but I could tell that clicking things
was working.  Manually removing the compiz option so it runs metacity instead
fixed the problem.

Not sure if this is the same issue, but I thought I would mention this.
Comment 21 chris desjardins 2008-08-06 16:22:51 EDT
I'm downloading the latest alpha version of f10 to test this and I'll report on it when it finishes.  Also it's very difficult for me to track rawhide on this laptop when the last time I used it I had no X so I can only really test this at milestone releases like alpha, beta, etc.
Comment 22 chris desjardins 2008-08-06 23:13:32 EDT
This is bug can be closed.  The openchrome driver on Fedora 10 alpha 1 is working.
Comment 23 Xavier Bachelot 2008-08-07 05:13:44 EDT
(In reply to comment #22)
> This is bug can be closed.  The openchrome driver on Fedora 10 alpha 1 is
> working.

Thx for testing, Chris. Could you please attach the xorg log and xorg conf ? I'll then close the bug.
Comment 24 Xavier Bachelot 2008-08-28 18:47:49 EDT
No log, too bad, but the bug is fixed, so let's close it.

Thanks and regards,
Xavier
Comment 25 chris desjardins 2008-08-28 23:58:29 EDT
Sorry.  My laptop is currently broken and was just sent in to HP for repair.  I'll report on this when I get it back.

Note You need to log in before you can comment on or make changes to this bug.