Bug 448027 - qt3's PATH not set properly unless qt3-devel is installed
qt3's PATH not set properly unless qt3-devel is installed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qt3 (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 20:43 EDT by Michel Alexandre Salim
Modified: 2008-07-02 23:13 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.3.8b-13.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 23:13:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2008-05-22 20:43:27 EDT
Description of problem:
/etc/profile.d/qt.{sh,csh} uses pkg-config to query the prefix of qt-mt. As such
the scripts should, if left unmodified, be part of qt3-devel and not the main
qt3 package.

Also, qt3-config installs a menu entry that assumes that the PATH has been
updated properly. Since the utility is useful to non-developers, we need to make
sure that either the PATH is updated without depending on pkg-config, or that
the full path to qtconfig is encoded in the desktop file?


Version-Release number of selected component (if applicable):
qt3-3.3.8b-12.fc9.x86_64
qt3-config-3.3.8b-12.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum install qt3-config
2. System->Preferences->Qt3 Config
3. cat /etc/profile.d/qt.sh
  
Actual results:
(2) fails with qtconfig not found; (3) uses pkgconfig
Comment 1 Ngo Than 2008-05-23 12:00:51 EDT
it's fixed in qt3-3_3_8b-13_fc9
Comment 2 Michel Alexandre Salim 2008-05-26 20:54:09 EDT
Koji says the build for FC9 was cancelled:
http://koji.fedoraproject.org/koji/buildinfo?buildID=50296

anything wrong with it?
Comment 3 Fedora Update System 2008-05-27 06:18:47 EDT
qt3-3.3.8b-13.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-05-28 22:47:06 EDT
qt3-3.3.8b-13.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt3'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4575
Comment 5 Fedora Update System 2008-07-02 23:13:02 EDT
qt3-3.3.8b-13.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.