Bug 448031 - Opening URL in Wine app corrupts Firefox contexts
Opening URL in Wine app corrupts Firefox contexts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 21:58 EDT by Michael Wiktowy
Modified: 2008-05-23 15:31 EDT (History)
3 users (show)

See Also:
Fixed In Version: 55
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-23 15:31:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample setroubleshooter alert (2.56 KB, text/plain)
2008-05-22 21:58 EDT, Michael Wiktowy
no flags Details

  None (edit)
Description Michael Wiktowy 2008-05-22 21:58:44 EDT
Description of problem:
An app (PokerStars client) that I ran under Wine opened a URL with the default
non-wine viewer, Firefox.

SETroubleshoot was not happy. Neither was Firefox at having selinux block access
to every file it needs to write to in ~.mozilla/. See attached sample
notification. You get several of the same type for Target Objects:
places.sqlite-journal [ filesystem ]
bookmarks-2008-05-22.json [ filesystem ]
localstore-1.rdf [ filesystem ]
patterns.ini [ filesystem ]
patterns.ini [ filesystem ]
urlclassifier3.sqlite-journal [ filesystem ]
cookies.sqlite-journal [ filesystem ]
formhistory.sqlite-journal [ filesystem ]
lock [ filesystem ]

Version-Release number of selected component (if applicable):
selinux-policy-3.3.1-51.fc9.noarch
selinux-policy-targeted-3.3.1-51.fc9.noarch
wine-0.9.58-1.fc9.i386

How reproducible:
Unknown since I didn't want to taunt selinux again but 'restorecon -R
~user/.mozilla/' fixes the issue with no data loss.

Steps to Reproduce:
1. Open a wine app that you can cause to load a URL (PokerStars client in my case)
2. Cause it to open a URL
3. Profit
  
Actual results:
Firefox unable to update or load bookmarks and other files under ~/.mozilla

Expected results:
Firefox should open and all should be well. I have done this sort of thing under
F8 with no ill effects.

Additional info:
If you don't use wine, let me know if you want any policies tested.
Comment 1 Michael Wiktowy 2008-05-22 21:58:44 EDT
Created attachment 306437 [details]
Sample setroubleshooter alert
Comment 2 Michael Wiktowy 2008-05-22 23:51:10 EDT
I cannot seem to recreate this bug after installing the following
updates-testing from koji:
selinux-policy-3.3.1-55.fc9.noarch
selinux-policy-devel-3.3.1-55.fc9.noarch
selinux-policy-targeted-3.3.1-55.fc9.noarch

Since I didn't try recreating this problem before updating I don't know if the
update fixed the problem (there didn't seem to be anything wine specific in the
latest changelogs) or it was not repeatable in the first place after a
restorecon to the .mozilla directory.

The good news is that things seem to work fine now :]
Comment 3 Daniel Walsh 2008-05-23 15:31:06 EDT
It might be a file system that we did not understand.

But for now, I will close as currentrelease, If you recreate reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.