Bug 448054 - bash completion when using scp is kind of broken
bash completion when using scp is kind of broken
Status: CLOSED DUPLICATE of bug 444466
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 03:53 EDT by Einars Lielmanis
Modified: 2008-05-23 08:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-23 08:54:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Einars Lielmanis 2008-05-23 03:53:30 EDT
Description of problem:

Bash-completion incorrectly clears already entered data when navigating remote
scp directories.

Version-Release number of selected component (if applicable):

Name       : bash-completion
Arch       : noarch
Version    : 20060301
Release    : 10

How reproducible:

(Server with setup public key ssh authentication needed)

# scp user@remote.host:fol<tab>
expected:
# scp user@remote.host:folder_name
got:
# scp folder_name

the connection information gets cut off.

Additional info:

Worked correctly in F8.
Comment 1 Ville Skyttä 2008-05-23 08:54:50 EDT
I'm guessing you have gvfs installed?  If yes, this is a duplicate of #444466
gvfs breaks all completions containing colons); otherwise, feel free to reopen.

*** This bug has been marked as a duplicate of 444466 ***

Note You need to log in before you can comment on or make changes to this bug.