Bug 448066 - Array indexing error in ReadCurve
Array indexing error in ReadCurve
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lcms (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 05:38 EDT by Takanori MATSUURA
Modified: 2008-06-20 15:15 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.17-5.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-20 15:07:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Takanori MATSUURA 2008-05-23 05:38:06 EDT
Lcms has Array indexing error in ReadCurve.
https://sourceforge.net/tracker/?func=detail&atid=386679&aid=1964283&group_id=26279
https://bugzilla.mozilla.org/show_bug.cgi?id=389867

I put this bug to upstream but get no response.
Comment 1 Nicolas Chauvet (kwizart) 2008-05-23 06:15:55 EDT
I think you should e-mail directly either the main developpers of lcms or Marti
Maria who wrote this particular file.
I often get low answear when i submit patch to sf in the patch/bug section.
You can also try the user-ml with better chances of success, see:
https://sourceforge.net/mailarchive/forum.php?forum_name=lcms-user

Now about xulrunner and lcms, i think that if that patch is really needed to
prevent bad errors with apps it would matter to backport it. But I really would
like to see an upstream advice about this question.
Comment 2 Takanori MATSUURA 2008-05-23 06:22:25 EDT
Thank you.

Yesterday I send email to "contact us" written in littlecms.com website.
Comment 3 Takanori MATSUURA 2008-05-23 12:08:38 EDT
I received the mail from LittleCMS Support and this will be fixed at the next
release.

But I think this should be fixed now because Firefox3 uses lcms (disabled as a
default but users can set "gfx.color_management.enabled" value to be enabled
from about:config).

I hope the patch provided by mozilla.org will be applied.
Comment 4 Fedora Update System 2008-06-03 05:50:41 EDT
lcms-1.17-5.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-06-03 05:51:31 EDT
lcms-1.17-5.fc9 has been submitted as an update for Fedora 9
Comment 6 Fedora Update System 2008-06-06 03:45:25 EDT
lcms-1.17-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lcms'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4976
Comment 7 Fedora Update System 2008-06-20 15:07:37 EDT
lcms-1.17-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-06-20 15:15:40 EDT
lcms-1.17-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.