This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 448093 - Xorg intel driver acceleration fails after suspend/resume
Xorg intel driver acceleration fails after suspend/resume
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 09:22 EDT by Oleg Mikheev
Modified: 2008-05-28 19:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 19:13:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full backtrace (13.48 KB, text/plain)
2008-05-23 09:22 EDT, Oleg Mikheev
no flags Details
Xorg.0.log (28.40 KB, text/plain)
2008-05-23 14:56 EDT, Oleg Mikheev
no flags Details

  None (edit)
Description Oleg Mikheev 2008-05-23 09:22:15 EDT
To put it short - Xorg acceleration produces a segmentation fault after
suspend/resume.

My system is Averatec 1020 laptop with Intel 855GM video, which worked perfectly
with i810 Xorg driver in Fedora 8. Then I installed Fedora 9.

Fedora 9  can't use i810 driver anymore, so I switched to intel.
I have desktop effects enabled, and after I resume suspended laptop Xorg hangs.

At first I thought it was compiz issue, and I turned it off.
Everything started to work just fine, suspend/resume worked great with
plain metacity.
Until I tried to run Mplayer. Running Mplayer froze the system.
I rebooted and ran Mplayer again - it worked just great.
Then I suspended/resumed, tried to run Mplayer - and yes! it hanged again!

Then I experimented with Openarena - exactly the same behavior!
If I run it on a freshly booted system it runs great, but if the system was
suspended just once running Openarena will hang the system!

So this issue is caused by ANY program trying to use (3d?) video acceleration.
Which would mean that it is an Xorg issue, most probably the new intel driver.

I connected a frozen system via ssh and here are the two last lines in dmesg:

[drm:i915_wait_irq] *ERROR* EBUSY -- rec: 33625 emitted: 33626
[drm:i915_wait_irq] *ERROR* EBUSY -- rec: 0 emitted: 33627

All that happened after I:
1. booted the laptop
2. started Openarena which ran fine
3. exited Openarena
4. suspended and resumed the laptop
5. tried to start Openarena which failed, but system didn't freeze although
screen resolution changed to 640x480
6. Ctrl-Alt-F1, init 3, init 5
7. Xorg restarted fine
8. ran Openarena, this time it froze the display, keyboard and mouse, but still
I could connect with ssh

I think that the first dmesg line was from my first failed Openarena attempt,
and the second one is from the second attempt

Xorg version:
xorg-x11-server-Xorg-1.4.99.901-29.20080415.fc9.i386
Comment 1 Oleg Mikheev 2008-05-23 09:22:15 EDT
Created attachment 306495 [details]
full backtrace
Comment 2 Oleg Mikheev 2008-05-23 09:23:47 EDT
GBD outputs this when Xorg hangs:

Program received signal SIGSEGV, Segmentation fault.
DRILock (pScreen=0x82762d8, flags=0) at dri.c:2181
2181        if (!*pDRIPriv->pLockRefCount) {


And this is my video h/w:

00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated
Graphics Device (rev 02) (prog-if 00 [VGA controller])
	Subsystem: TWINHEAD INTERNATIONAL Corp Unknown device 0319
	Flags: fast devsel, IRQ 16
	Memory at f0000000 (32-bit, prefetchable) [size=128M]
	Memory at feb80000 (32-bit, non-prefetchable) [size=512K]
	I/O ports at ec00 [size=8]
	Capabilities: [d0] Power Management version 1

00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics
Device (rev 02)
	Subsystem: TWINHEAD INTERNATIONAL Corp Unknown device 0319
	Flags: fast devsel
	Memory at e8000000 (32-bit, prefetchable) [size=128M]
	Memory at fea80000 (32-bit, non-prefetchable) [size=512K]
	Capabilities: [d0] Power Management version 1
Comment 3 Matěj Cepl 2008-05-23 12:59:32 EDT
Just to be sure we have all necessary information.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Oleg Mikheev 2008-05-23 14:56:03 EDT
Created attachment 306536 [details]
Xorg.0.log

I don't have xorg.conf in my system.
I used to have one in Fedora 8, but had to delete it in order for Fedora 9 to
work.
Comment 5 Oleg Mikheev 2008-05-28 11:22:25 EDT
This bug can be closed as 'Switched to Gentoo'.
Fedora is not usable for me in its current state.
Comment 6 Matěj Cepl 2008-05-28 19:13:01 EDT
Sorry to hear it. Oh well.

Note You need to log in before you can comment on or make changes to this bug.