Bug 448099 - tetex should restorecon -R /usr/share/texmf in %post
tetex should restorecon -R /usr/share/texmf in %post
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tetex (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Jindrich Novy
BaseOS QE
:
Depends On:
Blocks: 445005
  Show dependency treegraph
 
Reported: 2008-05-23 09:51 EDT by Milan Zazrivec
Modified: 2013-07-02 19:29 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, an error could have occurred and was logged when installing teTeX. This happened because several files installed in the /usr/share/texmf/ directory used an incorrect SELinux context. With this update, the files use the correct SELinux context and installation finishes without errors.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-20 09:41:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2008-05-23 09:51:50 EDT
Description of problem:
Several files under /usr/share/texmf owned by tetex are being installed
with incorrect selinux context (probably result of running texhash in %post).
tetex should restorecon -R /usr/share/texmf in %post to fix this.

Version-Release number of selected component (if applicable):
tetex-3.0-33.2.el5_1.2 / RHEL5.2 GA

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL5.2, tetex included, selinux enabled
2. # setfiles -vqn /etc/selinux/targeted/contexts/files/file_contexts \
     /usr/share/texmf|grep relabeling
Comment 1 Milan Zazrivec 2008-05-23 10:19:01 EDT
restorecon -R /usr/share/texmf in %post of tetex will not affect anaconda
installations, since policycoreutils (that restorecon is part of) is usually
installed after all tetex* packages.

David, would it be possible to fix the context of files under /usr/share/texmf
in anaconda using  setFileCons() ?
Comment 2 David Cantrell 2008-05-23 15:15:45 EDT
Yes, we can add it to the static list in anaconda that restorecon runs for.
Comment 3 RHEL Product and Program Management 2008-07-21 19:01:59 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 Chris Lumens 2009-02-03 10:37:47 EST
Putting all the possible files that could be modified by a package's %post script into a list in anaconda is not maintainable.  Instead, the tetex spec file should Requires(post): policycoreutils to make sure that package is installed early enough.  policycoreutils is going to get installed regardless, so not having a Requires doesn't help in any way.
Comment 15 errata-xmlrpc 2011-04-20 09:41:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0458.html
Comment 16 Eva Kopalova 2011-04-20 12:09:23 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, an error could have occurred and was logged when installing teTeX. This happened because several files installed in the /usr/share/texmf/ directory used an incorrect SELinux context. With this update, the files use the correct SELinux context and installation finishes without errors.

Note You need to log in before you can comment on or make changes to this bug.