Bug 448109 - Wrong module name for intel_master and intel_batchbuffer
Wrong module name for intel_master and intel_batchbuffer
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 10:39 EDT by Gustavo Junior Alves
Modified: 2009-07-14 13:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:42:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vncviewer on a machine with intel driver (445.48 KB, image/png)
2008-05-23 13:23 EDT, Gustavo Junior Alves
no flags Details
Results from X :1 -configure (1.46 KB, application/octet-stream)
2008-05-23 13:26 EDT, Gustavo Junior Alves
no flags Details
Xorg with problem loading intel modules (790 bytes, application/octet-stream)
2008-05-23 13:29 EDT, Gustavo Junior Alves
no flags Details
A log with the error (5.78 KB, application/octet-stream)
2008-05-23 13:33 EDT, Gustavo Junior Alves
no flags Details
Working log (26.86 KB, application/octet-stream)
2008-05-23 13:37 EDT, Gustavo Junior Alves
no flags Details
Modules errors in "Xorg -configure" (1.57 KB, text/plain)
2008-09-19 09:39 EDT, P3P
no flags Details
My xorg.conf (2.22 KB, application/octet-stream)
2008-09-19 09:41 EDT, P3P
no flags Details
My xorg log (21.86 KB, application/octet-stream)
2008-09-19 09:45 EDT, P3P
no flags Details

  None (edit)
Description Gustavo Junior Alves 2008-05-23 10:39:26 EDT
When I call startx using "intel" driver, I receive two error messeges:

(EE) Failed to load module "intelmaster" (module does not exist, 0)
(EE) Failed to load module "intelbatchbuffer" (module does not exist, 0)

With the "vannila" intel drivers, reinstalled from start, gives-me the same error.

This happens on Fedora 9. Never tested with other version.

To reproduce, use a hardware with an intel card interface. The problem can be
seen when you use applications like "vnc" on the device, that appears all video
wrong, just a "shadow" of the real image. When you change module to "vesa",
everything goes ok.

Steps to Reproduce:
1. Got a Intel video card. In this case, a Intel Corporation 82945G/GZ
Integrated Graphics Controller (rev 02) (8086:2772)

2. X -configure

3. Look for the error message
  
Actual results:

On log, you can see:
(EE) Failed to load module "intelmaster" (module does not exist, 0)
(EE) Failed to load module "intelbatchbuffer" (module does not exist, 0)

On applications, you can see strange things on VNC.

Expected results:

No error on log and VNC working ok.

Additional info:

I have a machine that can be used until May 26 to make any tests with this video
card.
Comment 1 Matěj Cepl 2008-05-23 12:55:51 EDT
Just to be sure, that we have all relevant information.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Gustavo Junior Alves 2008-05-23 13:23:27 EDT
Created attachment 306525 [details]
vncviewer on a machine with intel driver

This is the screenshot of a vncviewer session of Xorg from another Fedora
machine. The same screen can be seen on VNC for Windows. When changed the intel
driver to vesa, everything goes fine.
Comment 3 Gustavo Junior Alves 2008-05-23 13:26:16 EDT
Created attachment 306526 [details]
Results from X :1 -configure

When tried to autogenerate the config file using X :1 -configure, the results
appears as in this attachment.
Comment 4 Gustavo Junior Alves 2008-05-23 13:29:18 EDT
Created attachment 306527 [details]
Xorg with problem loading intel modules

This is the original file that I wrote for use with intel and vnc. From X, I
don't see any problems with those files. When I started to use with vnc, the
problem show up. Then, if I use any other driver, the problem goes away.
Comment 5 Gustavo Junior Alves 2008-05-23 13:33:51 EDT
Created attachment 306528 [details]
A log with the error

Thie is one from many tests I have done. Its possible to see the wrong module
loading.
Comment 6 Gustavo Junior Alves 2008-05-23 13:37:40 EDT
Created attachment 306529 [details]
Working log

I don't have any idea why, but the error goes away. From the various
tentatives, includes a installation from vanilla distribution of intel drivers
and some X recompilation.

The vnc still doens't work on intel. Maybe I assumed wrong the error from intel
driver is related with the vnc problem?
Comment 7 Matěj Cepl 2008-06-23 18:10:42 EDT
Is the issue reproduceable on the latest updates of your distribution?
Comment 8 Gustavo Junior Alves 2008-06-24 07:53:56 EDT
Unfortunally I doesn't have this machine anymore. :(
Comment 9 Matěj Cepl 2008-06-24 13:11:08 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received feedback to the
information we have requested above, we will assume the problem was not
reproducible, or has been fixed in one of the updates we have released for the
reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest
update of their distribution, and if this issue turns out to still be
reproducible in the latest update, please reopen this bug with additional
information.

Closing as INSUFFICIENT_DATA.
Comment 10 P3P 2008-09-19 09:39:23 EDT
Created attachment 317193 [details]
Modules errors in "Xorg -configure"
Comment 11 P3P 2008-09-19 09:41:14 EDT
Created attachment 317194 [details]
My xorg.conf
Comment 12 P3P 2008-09-19 09:45:40 EDT
Comment on attachment 317193 [details]
Modules errors in "Xorg -configure"

My display blinks when I move anything on screen, like when double framebuffer are not used.
The command "Xorg -configure" prints these messages:
(EE) Failed to load module "intelbatchbuffer" (module does not exist, 0)
(EE) Failed to load module "intelmaster" (module does not exist, 0)

Fedora 9 system.
Graphics card i740 (intel 82740) 
lspci:
01:05.0 VGA compatible controller: Intel Corporation 82740 (i740) AGP Graphics Accelerator (rev 21) (prog-if 00 [VGA controller])

# rpm -q xorg-x11-drv-i810
xorg-x11-drv-i810-2.3.2-2.fc9.i386
Comment 13 P3P 2008-09-19 09:45:52 EDT
Created attachment 317195 [details]
My xorg log
Comment 14 Bug Zapper 2009-06-09 21:07:01 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Bug Zapper 2009-07-14 13:42:02 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.