Bug 448127 - KOrganizer Reminder Daemons don't Remind if computer was turned off
KOrganizer Reminder Daemons don't Remind if computer was turned off
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
9
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 12:12 EDT by Peter Gückel
Modified: 2008-09-28 18:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-28 18:29:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 164088 None None None Never

  None (edit)
Description Peter Gückel 2008-05-23 12:12:01 EDT
Description of problem:
When KOrganizer triggers a reminder, one is given the option to suspend the
reminder for a duration of time. This works fine, as long as one doesn't turn
off the computer and back on again (this used to work correctly in kde3).

Version-Release number of selected component (if applicable):
kde4

How reproducible:
Wait until a reminder is triggered and select suspend and select a desired wait
time. If the computer remains turned on, it works, but if you power off and then
later back on again, KOrganizer forgets all suspended reminders.

Steps to Reproduce:
1.Set a reminder
2.Wait until it is triggerred
3.Suspend it for any desired duration
4.Turn off the computer and turn it back on again before the event is to be
triggerred again
5.You never get reminded
  
Actual results:
As described

Expected results:
As it used to be in previous versions of KDE (3, etc), the reminders should be
remembered even when the computer was turned off and should trigger at the set
time. For example, if one suspends the reminder for 5 hours and turns the
computer off for 2 hours and back on again, the reminder should still be
triggerred after 3 hours from the time it was turned back on again (ie, 5 hours
from when it was initially triggerred, regardless of whether the computer was
running or turned off during the interim).

Additional info:
none comes to mind
Comment 1 Kevin Kofler 2008-05-23 12:18:42 EDT
Uh, KOrganizer is part of kdepim which is still version 3.5.9 in F9 as in F8, 
so I'm not sure what's going on. Maybe it's setting itself up as a service in a 
KDE-3-specific path which KDE 4 doesn't know about?
Comment 2 Rex Dieter 2008-05-23 12:55:38 EDT
We're you using kdepim-3.5.9 on F8 when this was working?  Maybe what you're
seeing is a regression?
Comment 3 Peter Gückel 2008-05-30 21:12:49 EDT
Yes, it was working in F8, before KDE4 was released.
Comment 4 Rex Dieter 2008-05-30 21:18:29 EDT
Do you recall what version of kdepim you were using?  3.5.8? 3.5.9?
Comment 5 Peter Gückel 2008-06-01 20:40:42 EDT
I am not certain, but what I do know is that I always update my system to the
latest at least twice a day, and I enable testing repos for fedora and livna.
Comment 6 Steven M. Parrish 2008-06-08 20:28:17 EDT
Is this still an issue with KDE4.0.4?
Comment 7 Peter Gückel 2008-06-09 21:04:19 EDT
We have updated, as of last week, to KDE4.0.5. Yes, it is still an issue. The
reminders do not survive a power off, although in KDE3* they did.
Comment 8 Steven M. Parrish 2008-06-12 20:16:59 EDT
Ok checked upstream and could not find a matching bug.  Please add at upstream
report at bugs.kde.org   we will monitor upstream for a resolution.
Comment 9 Peter Gückel 2008-06-14 13:18:09 EDT
I don't have an account there. Guess I will have to. It is a vital function,
after all, that I use all the time, since I always turn my compute o ff when I'm
not using it.

I have switched to Rex' 4.0.80 and it is great, a vast improvement over 4.0.5,
but the problem persists.
Comment 10 Steven M. Parrish 2008-06-18 09:31:21 EDT
Were you able to report upstream?  If so please add upstream info to this
report, otherwise if you want I can file it upstream for you.

Comment 11 Peter Gückel 2008-06-18 12:34:20 EDT
I tried to report upstream on bugs.kde.org, but I am not sure if it 'took'. The
interface is very confusing, and I had to go through countless levels of
comparison with already existing bugs. As a 'mere' user, this is not my concern,
whether someone has already filed the same bug and then trying to determine what
he has decided to call it and how he decided to describe it. I experience a
problem and I report it. I tried to make a new bug report, but as yet there has
been no notification. That was a few days back now. Perhaps it was seem as a
duplicate? Perhaps they haven't gotten to processing it yet?
Comment 12 Steven M. Parrish 2008-06-20 16:59:47 EDT
Yes your bug was submitted see http://bugs.kde.org/show_bug.cgi?id=164088 
according to comments in the report the upstream developers have submitted a fix
for this issue.  Thanks
Comment 13 Rex Dieter 2008-06-20 17:15:29 EDT
I'm pretty sure that upstream bug is about a different issue, not this one. 
reopening (please feel free to correct me if my analysis is wrong).

kwhiskerz, if you're uncertain of the status of your upstream report, please try
filing it again.
Comment 14 Steven M. Parrish 2008-09-28 18:29:16 EDT
Its the same reporter with same issues mentioned.  Mark as fixed and closed upstream.

Note You need to log in before you can comment on or make changes to this bug.